summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-03-19 20:16:57 +0100
committerJohannes Huber <johu@gentoo.org>2016-03-21 11:47:06 +0100
commit3a926c800bfbb951cc31c691fb2ee30eb2bf1885 (patch)
treec9fba849de08b5574afb426673d46bed24f5af9f /app-text/ebook-tools/ebook-tools-0.2.2-r1.ebuild
parentdev-util/checkbashisms: Removed old. (diff)
downloadgentoo-3a926c800bfbb951cc31c691fb2ee30eb2bf1885.tar.gz
gentoo-3a926c800bfbb951cc31c691fb2ee30eb2bf1885.tar.bz2
gentoo-3a926c800bfbb951cc31c691fb2ee30eb2bf1885.zip
app-text/ebook-tools: Add lit2epub USE flag
Gentoo-bug: 530430
Diffstat (limited to 'app-text/ebook-tools/ebook-tools-0.2.2-r1.ebuild')
-rw-r--r--app-text/ebook-tools/ebook-tools-0.2.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/ebook-tools/ebook-tools-0.2.2-r1.ebuild b/app-text/ebook-tools/ebook-tools-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..6d1374e0da71
--- /dev/null
+++ b/app-text/ebook-tools/ebook-tools-0.2.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils multilib
+
+DESCRIPTION="Tools for accessing and converting various ebook file formats"
+HOMEPAGE="http://sourceforge.net/projects/ebook-tools"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd"
+IUSE="+lit2epub"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libzip
+"
+RDEPEND="${DEPEND}
+ lit2epub? ( app-text/convertlit )
+"
+
+DOCS=( INSTALL README TODO )
+
+src_prepare() {
+ default
+
+ use lit2epub || sed -i -e '\|lit2epub|d' -- 'src/tools/CMakeLists.txt' || die
+}