summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-19 10:20:58 -0500
committerMatt Turner <mattst88@gentoo.org>2023-02-19 10:23:23 -0500
commit05627fb2b7b9c7fb67d7526e7ee81872e9c2094a (patch)
treed67f9167a50fc4e333a59b849c0e0bcc0f972634 /app-text/enchant
parentsci-biology/pysam: add 0.20.0 (diff)
downloadgentoo-05627fb2b7b9c7fb67d7526e7ee81872e9c2094a.tar.gz
gentoo-05627fb2b7b9c7fb67d7526e7ee81872e9c2094a.tar.bz2
gentoo-05627fb2b7b9c7fb67d7526e7ee81872e9c2094a.zip
app-text/enchant: Version bump to 2.3.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/enchant')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.3.4.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 1d9db96e6dc9..631a47be6493 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,2 +1,3 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
DIST enchant-2.3.3.tar.gz 990877 BLAKE2B 310b66931e803ccb643a47c1476122a558de7a192b50f532d4cdababe55d398268bf5bfcc0ed556d665af88f6c183c1871147d302ad39a7ebd4fc29e1ab16967 SHA512 c97764a8f219033b440cbfb820624f54993b19ba1f38b56f20336889304f753c7c513008bb92cd1424bfbf528c2d473f35bef93d9140063612e3a270fd000deb
+DIST enchant-2.3.4.tar.gz 1015430 BLAKE2B 5a9c92b1c3767e4929c16b6429935c083cc733207434d7eeb3a28b384ff9287ecee6c756ff575a926f6e709179f2d6232e339bc007f200ba169251ad13a8fc34 SHA512 d109ab320ed84d6c9eec6c558c72a54d71ad30237c2bf11650b0e4030fbd9990a5ccf06a20851e46b6530279e1a9916b891cd394eefabc8812f7f92da62cbe1a
diff --git a/app-text/enchant/enchant-2.3.4.ebuild b/app-text/enchant/enchant-2.3.4.ebuild
new file mode 100644
index 000000000000..3c71c0775e63
--- /dev/null
+++ b/app-text/enchant/enchant-2.3.4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+IUSE="aspell +hunspell nuspell test voikko"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( aspell hunspell nuspell )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+ nuspell? ( >=app-text/nuspell-5.1.0:0= )
+ voikko? ( dev-libs/libvoikko )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-text/enchant-1.6.1-r2:0
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )
+"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable test relocatable)
+ $(use_with aspell)
+ $(use_with hunspell)
+ $(use_with nuspell)
+ $(use_with voikko)
+ --without-hspell
+ --without-applespell
+ --without-zemberek
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}