summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-05-24 08:10:41 -0400
committerMatt Turner <mattst88@gentoo.org>2023-05-24 08:12:31 -0400
commit23dff374b31792222345e2b23b4ef12b9e20ab3c (patch)
tree23d3a7b7800e443bb7a1069733573b96844e6be0 /app-text/enchant
parentnet-misc/dropbox: add 174.4.5852 (diff)
downloadgentoo-23dff374b31792222345e2b23b4ef12b9e20ab3c.tar.gz
gentoo-23dff374b31792222345e2b23b4ef12b9e20ab3c.tar.bz2
gentoo-23dff374b31792222345e2b23b4ef12b9e20ab3c.zip
app-text/enchant: Version bump to 2.5.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text/enchant')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.5.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 6a6ae76503e8..fb9386cc216a 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,3 +1,4 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
DIST enchant-2.3.4.tar.gz 1015430 BLAKE2B 5a9c92b1c3767e4929c16b6429935c083cc733207434d7eeb3a28b384ff9287ecee6c756ff575a926f6e709179f2d6232e339bc007f200ba169251ad13a8fc34 SHA512 d109ab320ed84d6c9eec6c558c72a54d71ad30237c2bf11650b0e4030fbd9990a5ccf06a20851e46b6530279e1a9916b891cd394eefabc8812f7f92da62cbe1a
DIST enchant-2.4.0.tar.gz 1013701 BLAKE2B cd67b2b68f247c6dbaa3f494541add67f908c794a9259b9ec63fe8063ae00da35317afd438c6c88d18e37ce57a1bd5ca055649684b981aaab367f7bb58af9d88 SHA512 fdffda2a81e5e66af25d2bac4c5350e3a514733667f5e8c0bc7d33fdd9517b396dfc23c600e8dfc94f33c5c68d7adf0ccf3a9ab6677f206e70bca1835a06713d
+DIST enchant-2.5.0.tar.gz 990061 BLAKE2B 297274e48de094815bc5bc105beebf6c3aa41d0d424ce277b348452cfaf2a07e3b71821dd63a0322e14fd3f8635b6d6a40fc84ea888aef9eb31175061149ef67 SHA512 3ab209b0b87b7cd8f94dd2bceed126d0e36252a1ede7a30b1550169555242784a631c0f259b0fe6591771da491ab934cac48f833029ba78dd779fc1ed91341fe
diff --git a/app-text/enchant/enchant-2.5.0.ebuild b/app-text/enchant/enchant-2.5.0.ebuild
new file mode 100644
index 000000000000..2e7316783b2a
--- /dev/null
+++ b/app-text/enchant/enchant-2.5.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+IUSE="aspell +hunspell nuspell test voikko"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( aspell hunspell nuspell )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+ nuspell? ( >=app-text/nuspell-5.1.0:0= )
+ voikko? ( dev-libs/libvoikko:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-text/enchant-1.6.1-r2:0
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )
+"
+BDEPEND="
+ sys-apps/groff
+ virtual/pkgconfig
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ alignof
+)
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable test relocatable)
+ $(use_with aspell)
+ $(use_with hunspell)
+ $(use_with nuspell)
+ $(use_with voikko)
+ --without-hspell
+ --without-applespell
+ --without-zemberek
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}