summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-10-04 10:00:04 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-10-04 10:00:15 +0200
commitb3b5de0bc5dcd25ff1db53be16414424fd780a87 (patch)
tree3007484336ff8eabae90a3640e85a6ae06924d74 /app-text/enchant
parentnet-im/telegram-desktop-bin: add missing gtk+:3 dep (diff)
downloadgentoo-b3b5de0bc5dcd25ff1db53be16414424fd780a87.tar.gz
gentoo-b3b5de0bc5dcd25ff1db53be16414424fd780a87.tar.bz2
gentoo-b3b5de0bc5dcd25ff1db53be16414424fd780a87.zip
app-text/enchant: add 2.6.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text/enchant')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.6.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 4209885fc5c9..9324c7998dbb 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,2 +1,3 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
DIST enchant-2.5.0.tar.gz 990061 BLAKE2B 297274e48de094815bc5bc105beebf6c3aa41d0d424ce277b348452cfaf2a07e3b71821dd63a0322e14fd3f8635b6d6a40fc84ea888aef9eb31175061149ef67 SHA512 3ab209b0b87b7cd8f94dd2bceed126d0e36252a1ede7a30b1550169555242784a631c0f259b0fe6591771da491ab934cac48f833029ba78dd779fc1ed91341fe
+DIST enchant-2.6.1.tar.gz 1014436 BLAKE2B 3df1d72d4fa2e912788d4e12e7bc4ab2676952e358e97457259284e78c32006482be0713059d5feeef56905e83ded975e7d723563c58e4f92c845b0b279a6827 SHA512 e2faabeb6a4edc7237a0a279b210512100fb1662b097cd23f0fc07a3519e48632e5527b0d393793a7623667011eae7e11f15fcddcaa155c4abd26ab6981ddf44
diff --git a/app-text/enchant/enchant-2.6.1.ebuild b/app-text/enchant/enchant-2.6.1.ebuild
new file mode 100644
index 000000000000..784efb038eaf
--- /dev/null
+++ b/app-text/enchant/enchant-2.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+IUSE="aspell +hunspell nuspell test voikko"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( aspell hunspell nuspell )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )
+ nuspell? ( >=app-text/nuspell-5.1.0:0= )
+ voikko? ( dev-libs/libvoikko:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ !<app-text/enchant-1.6.1-r2:0
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-libs/unittest++-2.0.0-r2 )
+"
+BDEPEND="
+ sys-apps/groff
+ virtual/pkgconfig
+"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ alignof
+ static_assert
+ unreachable
+)
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_enable test relocatable)
+ $(use_with aspell)
+ $(use_with hunspell)
+ $(use_with nuspell)
+ $(use_with voikko)
+ --without-hspell
+ --without-applespell
+ --without-zemberek
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}