summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/epstool
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/epstool')
-rw-r--r--app-text/epstool/Manifest1
-rw-r--r--app-text/epstool/epstool-3.08-r1.ebuild44
-rw-r--r--app-text/epstool/files/gcc43.patch20
-rw-r--r--app-text/epstool/metadata.xml7
4 files changed, 72 insertions, 0 deletions
diff --git a/app-text/epstool/Manifest b/app-text/epstool/Manifest
new file mode 100644
index 000000000000..503bc8e932e5
--- /dev/null
+++ b/app-text/epstool/Manifest
@@ -0,0 +1 @@
+DIST epstool-3.08.tar.gz 191567 SHA256 f3f14b95146868ff3f93c8720d5539deef3b6531630a552165664c7ee3c2cfdd SHA512 d6d70825c7d08cca318503bd8c12b48408b6d6cd3a64f26df94890373a3e73b68dc09a4eb454b81893c7ee3c11da791cdfed7466eb1410414cd1b97d80e8abf1 WHIRLPOOL 18b23dec04a5d08a849051fc8e0912f1bad5a73a2bcaff181a0a48bcce7fa0008ac1184bb4df6a74a0d7c64ce58b27d911195dd71d257201e0efad8afbe02d33
diff --git a/app-text/epstool/epstool-3.08-r1.ebuild b/app-text/epstool/epstool-3.08-r1.ebuild
new file mode 100644
index 000000000000..622cf5950d1f
--- /dev/null
+++ b/app-text/epstool/epstool-3.08-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Creates or extracts preview images in EPS files, fixes bounding boxes,converts to bitmaps"
+HOMEPAGE="http://www.cs.wisc.edu/~ghost/gsview/epstool.htm"
+SRC_URI="ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/ghostgum/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/gcc43.patch
+
+ sed -i \
+ -e '/^CC/s/=/?=/' \
+ -e '/^CLINK/s/gcc/$(CC)/' \
+ src/unixcom.mak || die
+ tc-export CC
+
+ epatch_user
+
+ # parallel make issue (bug #506978)
+ mkdir bin || die
+ mkdir epsobj || die
+}
+
+src_compile() {
+ emake epstool
+}
+
+src_install() {
+ dobin bin/epstool
+ doman doc/epstool.1
+ dohtml doc/epstool.htm doc/gsview.css
+}
diff --git a/app-text/epstool/files/gcc43.patch b/app-text/epstool/files/gcc43.patch
new file mode 100644
index 000000000000..b50250a9af1a
--- /dev/null
+++ b/app-text/epstool/files/gcc43.patch
@@ -0,0 +1,20 @@
+--- a/src/epstool.c
++++ b/src/epstool.c
+@@ -2824,7 +2824,7 @@
+ code = -1;
+ }
+ if ((code==0) && stdout_name && (hChildStdoutWr == -1)) {
+- handle = open(stdout_name, O_WRONLY | O_CREAT);
++ handle = open(stdout_name, O_WRONLY | O_CREAT, 0644);
+ hChildStdoutWr = dup2(handle, 1);
+ if (handle != -1)
+ close(handle);
+@@ -2832,7 +2832,7 @@
+ code = -1;
+ }
+ if ((code==0) && stderr_name && (hChildStderrWr == -1)) {
+- handle = open(stderr_name, O_WRONLY | O_CREAT);
++ handle = open(stderr_name, O_WRONLY | O_CREAT, 0644);
+ hChildStderrWr = dup2(handle, 2);
+ if (handle != -1)
+ close(handle);
diff --git a/app-text/epstool/metadata.xml b/app-text/epstool/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/app-text/epstool/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>