summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2022-03-31 09:46:12 -0500
committerBen Kohler <bkohler@gentoo.org>2022-03-31 09:46:57 -0500
commit5c2d773e025c827af755b1635653390dd133c0a0 (patch)
tree7bbd08d608e7a104770c84737796de777921a026 /app-text/grip
parentprofiles/arch/arm: drop pyside2 mask on QtPy (diff)
downloadgentoo-5c2d773e025c827af755b1635653390dd133c0a0.tar.gz
gentoo-5c2d773e025c827af755b1635653390dd133c0a0.tar.bz2
gentoo-5c2d773e025c827af755b1635653390dd133c0a0.zip
app-text/grip: add 4.6.1
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text/grip')
-rw-r--r--app-text/grip/Manifest1
-rw-r--r--app-text/grip/grip-4.6.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/grip/Manifest b/app-text/grip/Manifest
index 38f66c066d4e..d0f9c61e9c42 100644
--- a/app-text/grip/Manifest
+++ b/app-text/grip/Manifest
@@ -1,2 +1,3 @@
DIST grip-4.5.2.tar.gz 145644 BLAKE2B a353a74d55d6496f3dad362b74e434ff22c8130368f6773ab2bfdf66e43c62e8dcba0e3a786157d37b81d7c7e49d0c83a60c847100169684ede9c09f4eb06c3f SHA512 a8937d8ba3633a2d47587eb5c1b0583df7e8a8cacebb87fd50dab3fd2deb91981b38a83a3ed182f4e5e7435c8e2c8d87829e45fa9d32d8823c821f6217c7ccc9
DIST grip-4.6.0.tar.gz 147222 BLAKE2B ee5c10ca47ca0e9089d2618dc765a4ca01f4927da8c4256a251a9cf90ee15d63eb6136848cef0005d5f3af1f12b603f6f0fd55b65840bf542dcb9cd29ff35518 SHA512 483170996e593593781b684986dcb8eec20afb02dca84a9f5baeb3917220706332037f7b18f504aba8aa7d1d1c3587a1af18d6d5628f1e96517511c0be40a6ac
+DIST grip-4.6.1.tar.gz 147894 BLAKE2B e4f6b5c72e98b5d8ec443c794e95ff0a4250526dd7381f5a28da7d1119b607970593c4b3c22a49ec7da7d772e984abb2a0984ed7290b007e48cddf49bfc290ae SHA512 73eb80995457faa10ba5f174c8151c821f4bd9cda066099ba249cc5aad668e6adef267410ddd24fefa1d1e444c276a10a0881ec5e528bc616d3c4d98a8427b3d
diff --git a/app-text/grip/grip-4.6.1.ebuild b/app-text/grip/grip-4.6.1.ebuild
new file mode 100644
index 000000000000..1dc8182a71d1
--- /dev/null
+++ b/app-text/grip/grip-4.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Preview GitHub Markdown files like Readme locally before committing them"
+HOMEPAGE="https://github.com/joeyespo/grip"
+LICENSE="MIT"
+
+SLOT="0"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+KEYWORDS="~amd64"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ !media-sound/grip
+ >=dev-python/docopt-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/flask-0.10.1[${PYTHON_USEDEP}]
+ >=dev-python/markdown-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/path-and-address-2.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pygments-1.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.1[${PYTHON_USEDEP}]
+"