summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-24 23:26:31 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-24 23:29:49 +0000
commitd352d709a5c107127873987c3844b86ef949aaf8 (patch)
tree1af66119d015c4c2856f194db9ffe2b7ddeaa228 /app-text/highlight
parentapp-shells/dash: Bump to version 0.5.11.3 (diff)
downloadgentoo-d352d709a5c107127873987c3844b86ef949aaf8.tar.gz
gentoo-d352d709a5c107127873987c3844b86ef949aaf8.tar.bz2
gentoo-d352d709a5c107127873987c3844b86ef949aaf8.zip
app-text/highlight-2.14.3-r100: remove hardcoded -llua from the Qt project
Closes: https://bugs.gentoo.org/761511 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text/highlight')
-rw-r--r--app-text/highlight/files/highlight-3.57-qt_libs_lua.patch13
-rw-r--r--app-text/highlight/highlight-3.57-r100.ebuild6
2 files changed, 17 insertions, 2 deletions
diff --git a/app-text/highlight/files/highlight-3.57-qt_libs_lua.patch b/app-text/highlight/files/highlight-3.57-qt_libs_lua.patch
new file mode 100644
index 000000000000..02009164f4e9
--- /dev/null
+++ b/app-text/highlight/files/highlight-3.57-qt_libs_lua.patch
@@ -0,0 +1,13 @@
+Unnecessary (the linker gets the right library from pkgconfig anyway)
+and breaks slotted Lua. See Bug #761511 for details.
+
+--- a/src/gui-qt/highlight.pro
++++ b/src/gui-qt/highlight.pro
+@@ -39,7 +39,6 @@
+ unix {
+ DESTDIR = ../
+ LIBS += -L.. -lhighlight
+- LIBS += -llua
+ CONFIG += link_pkgconfig
+ PKGCONFIG += lua
+
diff --git a/app-text/highlight/highlight-3.57-r100.ebuild b/app-text/highlight/highlight-3.57-r100.ebuild
index 52f5375c3eee..4755abe9c040 100644
--- a/app-text/highlight/highlight-3.57-r100.ebuild
+++ b/app-text/highlight/highlight-3.57-r100.ebuild
@@ -34,6 +34,10 @@ BDEPEND="
qt5? ( dev-qt/linguist-tools:5 )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.57-qt_libs_lua.patch
+)
+
myhlopts=(
"CXX=$(tc-getCXX)"
"AR=$(tc-getAR)"
@@ -60,8 +64,6 @@ src_prepare() {
-e "/^LUA_.*pkg-config/s,\<lua\>,${ELUA},g" \
"${S}"/extras/tcl/makefile \
"${S}"/extras/swig/makefile \
- "${S}"/makefile \
- "${S}"/src/makefile \
|| die "Failed to set Lua implementation"
# We set it via eqmake5, otherwise it forces clang...