summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2017-09-09 18:55:52 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2017-09-09 19:26:49 -0400
commit748888f240ed319b9b7b912a24ca7d0c348ce877 (patch)
treeb80fae836ed833e16e6e607a3f77d2c11645a0ef /app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
parentsci-geosciences/qgis: Try to fix bug #612956 (diff)
downloadgentoo-748888f240ed319b9b7b912a24ca7d0c348ce877.tar.gz
gentoo-748888f240ed319b9b7b912a24ca7d0c348ce877.tar.bz2
gentoo-748888f240ed319b9b7b912a24ca7d0c348ce877.zip
app-text/htmlmin: Initial Commit
Required by dev-db/pgadmin4. Thanks to Chris Mayo for getting this started. Gentoo-Bug: 595378 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild')
-rw-r--r--app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild b/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
new file mode 100644
index 000000000000..89d79280a31f
--- /dev/null
+++ b/app-text/htmlmin/htmlmin-0.1.11_pre20170909.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+HTMLMIN_GIT_REVISION="7bcbb995778fc07e427872dc74af9646fd0c907d"
+
+DESCRIPTION="A configurable HTML Minifier with safety features"
+HOMEPAGE="https://github.com/mankyd/htmlmin"
+SRC_URI="https://github.com/mankyd/${PN}/archive/${HTMLMIN_GIT_REVISION}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed '/prune/d' -i MANIFEST.in
+ default
+}