summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2016-05-26 19:18:41 +0200
committerJohannes Huber <johu@gentoo.org>2016-05-26 19:20:47 +0200
commit19834ee0dee9d74c972de1be8efbbd3dc03341dc (patch)
tree772a00f5eb61e47b20d1604a2ab8250e27ed81fa /app-text/kding/kding-0.6-r3.ebuild
parentsys-apps/portage: x86 stable (bug #580738) (diff)
downloadgentoo-19834ee0dee9d74c972de1be8efbbd3dc03341dc.tar.gz
gentoo-19834ee0dee9d74c972de1be8efbbd3dc03341dc.tar.bz2
gentoo-19834ee0dee9d74c972de1be8efbbd3dc03341dc.zip
app-text/kding: Fix broken png with libpng-1.6
Gentoo-bug: 510510 Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'app-text/kding/kding-0.6-r3.ebuild')
-rw-r--r--app-text/kding/kding-0.6-r3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/kding/kding-0.6-r3.ebuild b/app-text/kding/kding-0.6-r3.ebuild
new file mode 100644
index 000000000000..5227bb44b4ee
--- /dev/null
+++ b/app-text/kding/kding-0.6-r3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="de"
+inherit kde4-base
+
+DESCRIPTION="KDE port of Ding, a dictionary lookup program"
+HOMEPAGE="http://www.rexi.org/software/kding/"
+SRC_URI="http://www.rexi.org/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="media-libs/libpng:0"
+
+PATCHES=(
+ "${FILESDIR}/${P}-dtd.patch"
+ "${FILESDIR}/${P}-cmake.patch"
+)
+
+src_prepare() {
+ sed -e "/Encoding=UTF-8/d" \
+ -i resources/kding.desktop || die "fixing .desktop file failed"
+
+ kde4-base_src_prepare
+}
+
+src_install() {
+ kde4-base_src_install
+
+ # bug 510510
+ pngfix -q --out=out.png "${ED}/usr/share/icons/hicolor/22x22/apps/kding.png"
+ mv -f out.png "${ED}/usr/share/icons/hicolor/22x22/apps/kding.png" \
+ || die "fixing broken png file failed"
+}