summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-09 20:57:24 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-10-09 20:57:24 +0200
commit4bf6c1938c37f47f1de32fa92b0833cc225eb229 (patch)
tree1227f7bf02b0406dcd3a5a4296cb9a925f912dd1 /app-text/krop
parentnet-im/teams: Version bump (diff)
downloadgentoo-4bf6c1938c37f47f1de32fa92b0833cc225eb229.tar.gz
gentoo-4bf6c1938c37f47f1de32fa92b0833cc225eb229.tar.bz2
gentoo-4bf6c1938c37f47f1de32fa92b0833cc225eb229.zip
app-text/krop: Version bump
Closes: https://bugs.gentoo.org/746671 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/Manifest1
-rw-r--r--app-text/krop/krop-0.6.0.ebuild42
-rw-r--r--app-text/krop/krop-9999.ebuild3
3 files changed, 45 insertions, 1 deletions
diff --git a/app-text/krop/Manifest b/app-text/krop/Manifest
index 0d4e2b12d737..d3a11c644589 100644
--- a/app-text/krop/Manifest
+++ b/app-text/krop/Manifest
@@ -1 +1,2 @@
DIST krop-0.5.1.tar.gz 42719 BLAKE2B e0baa3c14d9ce63815615eae004a08af720868d584262901eccbc569852177e07d5df659ea560d7e9cbdc4325daef8c35acd9c200440a8dfd73c19b274d8de37 SHA512 2bfd2a5d762454ab45538707c6f333d2b0947b6b203d6e7bd2d9d0d574d79de8ee6b30d87b17d6afea604456b915f323b855c9c9af5c169c192b0a01634075ca
+DIST krop-0.6.0.tar.gz 48331 BLAKE2B ca6a00a410ed4e18a401fab3a21bc49c86f73165f68b192ab83c8fad74111ba9a9941f464a2646faa5a3317bbb45cdc89bed19c901999c0b11db353ac2997a65 SHA512 51a988e4fcb65d11cc26cf5b0c808e79097a66ef8ec4751a6c051289cd77b3328ebc8ecd9829adc466f87330beb8bc715d290cc20be415a7b8f179378b7bcb4f
diff --git a/app-text/krop/krop-0.6.0.ebuild b/app-text/krop/krop-0.6.0.ebuild
new file mode 100644
index 000000000000..3f7134934cdd
--- /dev/null
+++ b/app-text/krop/krop-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
+else
+ SRC_URI="https://github.com/arminstraub/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},gui,widgets]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
diff --git a/app-text/krop/krop-9999.ebuild b/app-text/krop/krop-9999.ebuild
index 5dbe780b3d81..3f7134934cdd 100644
--- a/app-text/krop/krop-9999.ebuild
+++ b/app-text/krop/krop-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit desktop distutils-r1 xdg-utils
@@ -10,7 +11,7 @@ if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
else
- SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+ SRC_URI="https://github.com/arminstraub/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi