summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 17:43:36 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 17:43:36 +0100
commit6455341aa2191caea132fe3361f1adaf3e2cd5d7 (patch)
tree3db51d5b3fb00bdcc9919057e53acea315718e1a /app-text/krop
parentapp-backup/tsm: Use slotted fuse dependency, bug 668054 (diff)
downloadgentoo-6455341aa2191caea132fe3361f1adaf3e2cd5d7.tar.gz
gentoo-6455341aa2191caea132fe3361f1adaf3e2cd5d7.tar.bz2
gentoo-6455341aa2191caea132fe3361f1adaf3e2cd5d7.zip
app-text/krop: Version bump
Closes: https://bugs.gentoo.org/616432 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/Manifest1
-rw-r--r--app-text/krop/krop-0.5.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-text/krop/Manifest b/app-text/krop/Manifest
index 09de9810a232..578ea1b0f2f1 100644
--- a/app-text/krop/Manifest
+++ b/app-text/krop/Manifest
@@ -1 +1,2 @@
DIST krop-0.4.13.5.tar.gz 40079 BLAKE2B 9d3505f7d9cbf0eef4ec7a28928f14940e6c0a2fd4499b6c5896fde7b3f7b8a0b84ddc4f9c7735ee348f89e9924a7b8f69a3d4dbfaa4668ac770a0fe8404d469 SHA512 218eb3e256dabcacc53af62b2e704031bd21bedacf2599c4aed7ee3b3847b35741c921a08137b7b6e7295ddfc7f87f4ffbf9d3fec3fb137d1ce36e3945dc6129
+DIST krop-0.5.1.tar.gz 42719 BLAKE2B e0baa3c14d9ce63815615eae004a08af720868d584262901eccbc569852177e07d5df659ea560d7e9cbdc4325daef8c35acd9c200440a8dfd73c19b274d8de37 SHA512 2bfd2a5d762454ab45538707c6f333d2b0947b6b203d6e7bd2d9d0d574d79de8ee6b30d87b17d6afea604456b915f323b855c9c9af5c169c192b0a01634075ca
diff --git a/app-text/krop/krop-0.5.1.ebuild b/app-text/krop/krop-0.5.1.ebuild
new file mode 100644
index 000000000000..21e6ff172169
--- /dev/null
+++ b/app-text/krop/krop-0.5.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit eutils distutils-r1 xdg-utils
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}