summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 17:52:23 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2018-12-25 17:52:23 +0100
commit9852514221dd61b940ac6337222febda119a14e4 (patch)
tree88dbf2cebea677958949a403016729da04f5cfa8 /app-text/krop
parentapp-text/krop: Remove old (diff)
downloadgentoo-9852514221dd61b940ac6337222febda119a14e4.tar.gz
gentoo-9852514221dd61b940ac6337222febda119a14e4.tar.bz2
gentoo-9852514221dd61b940ac6337222febda119a14e4.zip
app-text/krop: Add live ebuild
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'app-text/krop')
-rw-r--r--app-text/krop/krop-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-text/krop/krop-9999.ebuild b/app-text/krop/krop-9999.ebuild
new file mode 100644
index 000000000000..442ae81d8fdf
--- /dev/null
+++ b/app-text/krop/krop-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit desktop distutils-r1 xdg-utils
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/arminstraub/krop.git"
+else
+ SRC_URI="http://arminstraub.com/downloads/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A tool to crop PDF files"
+HOMEPAGE="http://arminstraub.com/software/krop"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-python/python-poppler-qt5[${PYTHON_USEDEP}]
+ dev-python/PyPDF2[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]"
+
+src_install() {
+ distutils-r1_src_install
+ domenu "${WORKDIR}/${P}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}