summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 00:34:14 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-07 00:34:35 +0200
commitf39664e2abc1387141a5172304b9301a9130bf8c (patch)
tree77ba25146145802f0b0233d91d092f8751dbc5c3 /app-text/libepubgen
parentmedia-libs/vigra: Remove old (diff)
downloadgentoo-f39664e2abc1387141a5172304b9301a9130bf8c.tar.gz
gentoo-f39664e2abc1387141a5172304b9301a9130bf8c.tar.bz2
gentoo-f39664e2abc1387141a5172304b9301a9130bf8c.zip
app-text/libepubgen: 0.1.1 version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/libepubgen')
-rw-r--r--app-text/libepubgen/Manifest1
-rw-r--r--app-text/libepubgen/libepubgen-0.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/app-text/libepubgen/Manifest b/app-text/libepubgen/Manifest
index d6c2270c8eee..618021563d80 100644
--- a/app-text/libepubgen/Manifest
+++ b/app-text/libepubgen/Manifest
@@ -1 +1,2 @@
DIST libepubgen-0.1.0.tar.xz 319652 BLAKE2B e6573e0a680711380ac3d2ef742413e38030e76dc50639f9659544e7410f7d7f987cdf1aa20cf2f2afa924bbcbecaf7141225d387fc509d0db6387cd144cb16e SHA512 6be431d06321807991048567aebd7111359f8aa364fe33e651c991553f832c03ad3bb3520b9f7e8d72a861a9ebd84483587becb9062e226bcd1d8ade1819b4a9
+DIST libepubgen-0.1.1.tar.xz 324380 BLAKE2B f2dd4ee4987aa69f3972f83fe6348e8f0d4ba2d5c2f8f871e81d7e9dd5dcc00e10fc2be27fcbbb6170f5a673b86c62261fb8d25ff3bf788cda726e64a254ec7d SHA512 9d911384672b5394ff1df3280a5c9fe12888530c41f177aa100f135954e2ec279b64193f8388f12c96f6a6e587483ce853e74fe45b29fb748a930512dd011c2b
diff --git a/app-text/libepubgen/libepubgen-0.1.1.ebuild b/app-text/libepubgen/libepubgen-0.1.1.ebuild
new file mode 100644
index 000000000000..2fe034fa1608
--- /dev/null
+++ b/app-text/libepubgen/libepubgen-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EPUB generator for librevenge"
+HOMEPAGE="https://sourceforge.net/projects/libepubgen/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug doc test"
+
+RDEPEND="
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? (
+ dev-util/cppunit
+ dev-libs/libxml2:2
+ )
+"
+
+src_configure() {
+ econf \
+ --disable-weffc \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}