summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-27 23:20:56 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-27 23:42:46 +0200
commit6f443654e79d378dda4102d916e551105402ad25 (patch)
tree585ef9e7e0382ec50060993b245acfb5a14d7f96 /app-text/libetonyek
parentapp-text/libmwaw: 0.3.14 version bump (diff)
downloadgentoo-6f443654e79d378dda4102d916e551105402ad25.tar.gz
gentoo-6f443654e79d378dda4102d916e551105402ad25.tar.bz2
gentoo-6f443654e79d378dda4102d916e551105402ad25.zip
app-text/libetonyek: 0.1.8 version bump
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'app-text/libetonyek')
-rw-r--r--app-text/libetonyek/Manifest1
-rw-r--r--app-text/libetonyek/libetonyek-0.1.8.ebuild53
-rw-r--r--app-text/libetonyek/libetonyek-9999.ebuild2
3 files changed, 55 insertions, 1 deletions
diff --git a/app-text/libetonyek/Manifest b/app-text/libetonyek/Manifest
index 44f94a3f6d82..3214bbfef5bf 100644
--- a/app-text/libetonyek/Manifest
+++ b/app-text/libetonyek/Manifest
@@ -1 +1,2 @@
DIST libetonyek-0.1.7.tar.xz 1256232 BLAKE2B ef2abcc427014d515a75ff75d90a78da0b5b28d54b5de3793540e8448f163da0b6d3ff4026373ffc3a4973d3e0e4fee280e75a77407620b3ba0e833bd7d8c82a SHA512 bec4819e161f68b7315567464bfe9e0259a59822a7926c54208cceb04061664a1220716539816a24a6f259eac6f7063c72750aaaf8d8886e3bfb0c4d5f1e0b0f
+DIST libetonyek-0.1.8.tar.xz 1324868 BLAKE2B 2088349df75011f54f5822ffd69336a7942a148ff829111c02efbfb99c705a9e00105147942f3e9e81278be3b1f2be4d63aba8cbf6a54127f04fc547df6b7b1d SHA512 c8c08100b0c75e0420bbcd796f7cb9285e77ce1be34757df5b237d114a428a4a6094f12e442f81769a2fac5be45ea4376ff9e1d90448e18b3443bfe7c645a865
diff --git a/app-text/libetonyek/libetonyek-0.1.8.ebuild b/app-text/libetonyek/libetonyek-0.1.8.ebuild
new file mode 100644
index 000000000000..39b6f10a69f8
--- /dev/null
+++ b/app-text/libetonyek/libetonyek-0.1.8.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/libreoffice/libetonyek.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing Apple Keynote presentations"
+HOMEPAGE="https://wiki.documentfoundation.org/DLP/Libraries/libetonyek"
+[[ ${PV} == 9999 ]] || SRC_URI="https://dev-www.libreoffice.org/src/libetonyek/${P}.tar.xz"
+
+LICENSE="|| ( GPL-2+ LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc static-libs test"
+
+RDEPEND="
+ app-text/liblangtag
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ >=dev-util/mdds-1.2.2:1
+ media-libs/glm
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cppunit )
+"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_with doc docs) \
+ $(use_enable static-libs static) \
+ $(use_enable test tests) \
+ --with-mdds=1.2
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libetonyek/libetonyek-9999.ebuild b/app-text/libetonyek/libetonyek-9999.ebuild
index fc13ce6b6bec..39b6f10a69f8 100644
--- a/app-text/libetonyek/libetonyek-9999.ebuild
+++ b/app-text/libetonyek/libetonyek-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6