summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-29 21:42:48 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-11-29 21:48:54 +0100
commit6bcd4f96bf81b18fccba2e6beff35406af3bce0e (patch)
tree574e82b23650e182dbaa6eaf66f65a419776b72f /app-text/libmwaw
parentx11-misc/nts: Drop old (diff)
downloadgentoo-6bcd4f96bf81b18fccba2e6beff35406af3bce0e.tar.gz
gentoo-6bcd4f96bf81b18fccba2e6beff35406af3bce0e.tar.bz2
gentoo-6bcd4f96bf81b18fccba2e6beff35406af3bce0e.zip
app-text/libmwaw: Version bump
Package-Manager: portage-2.3.2
Diffstat (limited to 'app-text/libmwaw')
-rw-r--r--app-text/libmwaw/Manifest1
-rw-r--r--app-text/libmwaw/libmwaw-0.3.9.ebuild54
-rw-r--r--app-text/libmwaw/libmwaw-9999.ebuild7
3 files changed, 59 insertions, 3 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index e908d57030b1..fdf6791a5965 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1 +1,2 @@
DIST libmwaw-0.3.8.tar.xz 1200052 SHA256 6afcbb250b6bed042149cd4dfb3ba7b4be796b11fe2322dfcdebd121199a3b05 SHA512 3e3684479460d22b83da225f8f1bc4de306f8e4a9e48c7ea128cba08f122b093c529f2e73b8f8ae1b235665d4f3c7de2fc461692e21f13364da678add707d01c WHIRLPOOL 77d9b1253191089da5c869e7bb160253672747cfd502350b28acde538e02b8418c0ee63899bf903b4c3c9f1561d145d0626c822f26467cb8ba7aa4de04287158
+DIST libmwaw-0.3.9.tar.xz 1226044 SHA256 f7fca4d31510e52cda94f1272147f385e372448c0aaef16f07a5e8b3ceb5b2a0 SHA512 41ed9adbe4d73f0554629394f33b20c11ead86b1922af37451fa8c7179d55d61b09da72d676fb0ce123818675450048a87b9f4d67ad2e8070269724bd2cd0051 WHIRLPOOL 88eac9a04707249ebb874504b2012786b2b21f1e2fd42f07d3a809bef343b6a1ad5cb3ffebb484c2da52bc47ff3050f98d8e64dacabe8caca1e7a5e75b4f8d90
diff --git a/app-text/libmwaw/libmwaw-0.3.9.ebuild b/app-text/libmwaw/libmwaw-0.3.9.ebuild
new file mode 100644
index 000000000000..a8a3aae2772a
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
+inherit eutils
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
+[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE="doc static-libs"
+
+RDEPEND="
+ dev-libs/librevenge
+ dev-libs/libxml2
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/boost-1.46:=
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --with-sharedptr=boost \
+ --enable-zip \
+ --disable-werror \
+ $(use_enable static-libs static) \
+ $(use_with doc docs)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/app-text/libmwaw/libmwaw-9999.ebuild b/app-text/libmwaw/libmwaw-9999.ebuild
index d1a398943449..a8a3aae2772a 100644
--- a/app-text/libmwaw/libmwaw-9999.ebuild
+++ b/app-text/libmwaw/libmwaw-9999.ebuild
@@ -1,15 +1,15 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
EGIT_REPO_URI="git://git.code.sf.net/p/libmwaw/libmwaw"
inherit eutils
[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="Library parsing many pre-OSX MAC text formats"
-HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+HOMEPAGE="http://sourceforge.net/p/libmwaw/wiki/Home/"
[[ ${PV} == 9999 ]] || SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
"
src_prepare() {
+ default
[[ ${PV} == 9999 ]] && eautoreconf
}