summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-11-08 23:42:15 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2017-11-08 23:46:03 +0100
commitd0c8b3df0cf995e3e7218e2031dfae55ef42e54a (patch)
tree75c3b8d6be5bbc890d284cc2f305d804abbecfe6 /app-text/libstaroffice
parentsys-apps/util-linux: stable 2.30.2 for sparc, bug #636626 (thanks to Rolf Eik... (diff)
downloadgentoo-d0c8b3df0cf995e3e7218e2031dfae55ef42e54a.tar.gz
gentoo-d0c8b3df0cf995e3e7218e2031dfae55ef42e54a.tar.bz2
gentoo-d0c8b3df0cf995e3e7218e2031dfae55ef42e54a.zip
app-text/libstaroffice: 0.0.5 version bump
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'app-text/libstaroffice')
-rw-r--r--app-text/libstaroffice/Manifest1
-rw-r--r--app-text/libstaroffice/libstaroffice-0.0.5.ebuild45
-rw-r--r--app-text/libstaroffice/libstaroffice-9999.ebuild2
3 files changed, 47 insertions, 1 deletions
diff --git a/app-text/libstaroffice/Manifest b/app-text/libstaroffice/Manifest
index 3d11505a4c65..eda1b8ee4bac 100644
--- a/app-text/libstaroffice/Manifest
+++ b/app-text/libstaroffice/Manifest
@@ -1,2 +1,3 @@
DIST libstaroffice-0.0.3.tar.xz 679800 SHA256 bedeec104b4cc3896b3dfd1976dda5ce7392d1942bf8f5d2f7d796cc47e422c6 SHA512 ea60576537761a5b969a861ac43c8d4a9da5e5261d0a31f3d7743f8507e6979ccd4cba1784e8c3d909c08b692349ae11e87428834fd3df5b8d56e423caa7bcd8 WHIRLPOOL c8ba69eb347aa0c77f886511d79dba5011aa0ff25c3e9f4ec4af31b8b9303fd9dc1df32742bbc3c87d2a7fba32a7f830fdc3a38ca391559038388f4d97afe9af
DIST libstaroffice-0.0.4.tar.xz 681828 SHA256 6e728784d002144716b10fe122973b3e4edda9004538386b0b58bb303404903a SHA512 d591e554ce108165f1952ae82835241df0f986ce51f1a4fe43d282733358bb8d72418621f91f431367a5c09f9a40a9784666ffa2da303c5543ee000b1d6abf38 WHIRLPOOL ac295aa290f92bc2071a56439dafb4280c52e2de8e36e6e686cdf31150bff8c87989bbc693cc4175d96c1ae5a155f21bb8f9344b0ed10920ebec161ba20a7110
+DIST libstaroffice-0.0.5.tar.xz 682380 SHA256 315507add58068aa6d5c437e7c2a6fd1abe684515915152c6cf338fc588da982 SHA512 937fc618bef79c9e25957f25f39bc829621b0a2da0213cbfb1b56c2b00d44f61bcd9db67d3e6329a4bd700a2c88fc743088381f58a96a87712b040c0ffc17fde WHIRLPOOL 13d97a0253020fcf485841fe7657fd1a8de54d0afddbcfb16624eb63bc0983b028cdfe5ba5c6666b570ac6e4578c47a452c9b6f1b79016989d7896045db70625
diff --git a/app-text/libstaroffice/libstaroffice-0.0.5.ebuild b/app-text/libstaroffice/libstaroffice-0.0.5.ebuild
new file mode 100644
index 000000000000..20a958e6735b
--- /dev/null
+++ b/app-text/libstaroffice/libstaroffice-0.0.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/fosnola/libstaroffice.git"
+[[ ${PV} == 9999 ]] && inherit git-r3 autotools
+
+DESCRIPTION="Import filter for old StarOffice documents"
+HOMEPAGE="https://github.com/fosnola/libstaroffice"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+IUSE="debug doc tools +zlib"
+
+RDEPEND="
+ dev-libs/librevenge
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_with doc docs) \
+ $(use_enable tools) \
+ $(use_enable zlib zip)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-text/libstaroffice/libstaroffice-9999.ebuild b/app-text/libstaroffice/libstaroffice-9999.ebuild
index 57dbc81af329..20a958e6735b 100644
--- a/app-text/libstaroffice/libstaroffice-9999.ebuild
+++ b/app-text/libstaroffice/libstaroffice-9999.ebuild
@@ -13,7 +13,7 @@ HOMEPAGE="https://github.com/fosnola/libstaroffice"
LICENSE="|| ( LGPL-2.1+ MPL-2.0 )"
SLOT="0"
[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~arm ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
IUSE="debug doc tools +zlib"