summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrahmajit Das <brahmajit.xyz@gmail.com>2023-08-02 16:16:26 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-08-19 15:51:08 +0300
commit957db3f2129168918147c91c23114508b0f40931 (patch)
treee52a4788540f52de711219de6871e50e821bbeb3 /app-text/mecab
parentapp-i18n/mecab-skkserv: Fix call to undeclared library function strcmp (diff)
downloadgentoo-957db3f2129168918147c91c23114508b0f40931.tar.gz
gentoo-957db3f2129168918147c91c23114508b0f40931.tar.bz2
gentoo-957db3f2129168918147c91c23114508b0f40931.zip
app-text/mecab: Fix no template named binary_function
Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32144 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/mecab')
-rw-r--r--app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch16
-rw-r--r--app-text/mecab/mecab-0.996-r2.ebuild60
2 files changed, 76 insertions, 0 deletions
diff --git a/app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch b/app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch
new file mode 100644
index 000000000000..5776cf5b2aa5
--- /dev/null
+++ b/app-text/mecab/files/mecab-0.996-clang-16-binary_function.patch
@@ -0,0 +1,16 @@
+Dropping usage of binary_function
+--- a/src/dictionary.cpp
++++ b/src/dictionary.cpp
+@@ -65,7 +65,11 @@ int progress_bar_darts(size_t current, size_t total) {
+ }
+
+ template <typename T1, typename T2>
+-struct pair_1st_cmp: public std::binary_function<bool, T1, T2> {
++struct pair_1st_cmp {
++ public:
++ using first_argument_type = bool;
++ using second_argument_type = T1;
++ using result_type = T2;
+ bool operator()(const std::pair<T1, T2> &x1,
+ const std::pair<T1, T2> &x2) {
+ return x1.first < x2.first;
diff --git a/app-text/mecab/mecab-0.996-r2.ebuild b/app-text/mecab/mecab-0.996-r2.ebuild
new file mode 100644
index 000000000000..078cd4f66a9d
--- /dev/null
+++ b/app-text/mecab/mecab-0.996-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Yet Another Part-of-Speech and Morphological Analyzer"
+HOMEPAGE="https://taku910.github.io/mecab/"
+SRC_URI="https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( BSD LGPL-2.1 GPL-2 )"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+IUSE="static-libs unicode"
+
+BDEPEND="
+ dev-lang/perl
+ sys-devel/gettext
+"
+DEPEND="virtual/libiconv"
+RDEPEND="${DEPEND}"
+PDEPEND="
+ || (
+ app-dicts/mecab-ipadic[unicode=]
+ app-dicts/mecab-naist-jdic[unicode=]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.98-iconv.patch
+ "${FILESDIR}"/${PN}-0.996-clang-16-register.patch
+ "${FILESDIR}"/${PN}-0.996-clang-16-binary_function.patch
+)
+
+HTML_DOCS=( doc/. )
+
+src_prepare() {
+ default
+ sed -i \
+ -e "/CFLAGS/s/-O3/${CFLAGS}/" \
+ -e "/CXXFLAGS/s/-O3/${CXXFLAGS}/" \
+ configure.in
+ sed -i "s:/lib:/$(get_libdir):" ${PN}rc.in
+
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with unicode charset UTF-8)
+}
+
+src_install() {
+ default
+ find "${ED}" -name 'Makefile*' -delete || die
+ use static-libs || find "${ED}" -name '*.la' -delete || die
+}