summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/multitail/multitail-6.4.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/multitail/multitail-6.4.1.ebuild')
-rw-r--r--app-text/multitail/multitail-6.4.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-text/multitail/multitail-6.4.1.ebuild b/app-text/multitail/multitail-6.4.1.ebuild
new file mode 100644
index 000000000000..89a0195d90ab
--- /dev/null
+++ b/app-text/multitail/multitail-6.4.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tail with multiple windows"
+HOMEPAGE="http://www.vanheusden.com/multitail/"
+SRC_URI="http://www.vanheusden.com/multitail/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="debug examples unicode"
+
+RDEPEND="
+ sys-libs/ncurses[unicode?]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+RESTRICT="test" # bug #492270
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-6.4.1-gentoo.patch
+
+ sed \
+ -e "/^DESTDIR/s:=.*$:=${EROOT}:g" \
+ -i Makefile || die
+
+ sed \
+ -e "s:/usr/bin/xclip:${EPREFIX}/usr/bin/xclip:g" \
+ -i xclip.c ${PN}.conf || die
+
+ tc-export CC PKG_CONFIG
+
+ use debug && append-flags "-D_DEBUG"
+}
+
+src_compile() {
+ emake UTF8_SUPPORT=$(usex unicode)
+}
+
+src_install () {
+ dobin multitail
+
+ insinto /etc
+ doins multitail.conf
+
+ DOCS=( readme.txt thanks.txt )
+ HTML_DOCS=( manual.html )
+ einstalldocs
+
+ doman multitail.1
+
+ if use examples; then
+ docinto examples
+ dodoc conversion-scripts/colors-example.{pl,sh} conversion-scripts/convert-{geoip,simple}.pl
+ fi
+}
+
+pkg_postinst() {
+ optfeature "send a buffer to the X clipboard" x11-misc/xclip
+}