summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-01-21 22:50:52 +0100
committerDavid Seifert <soap@gentoo.org>2020-01-21 22:50:52 +0100
commit94c0dd1173d7f0ee764c2f3f30658aae7fd012a5 (patch)
treeea12ce828d6475b8470daa436b33991cf71a37b0 /app-text/o3read
parentapp-text/libxmlpatch: Port to EAPI 7 (diff)
downloadgentoo-94c0dd1173d7f0ee764c2f3f30658aae7fd012a5.tar.gz
gentoo-94c0dd1173d7f0ee764c2f3f30658aae7fd012a5.tar.bz2
gentoo-94c0dd1173d7f0ee764c2f3f30658aae7fd012a5.zip
app-text/o3read: Port to EAPI 7
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/o3read')
-rw-r--r--app-text/o3read/files/o3read-0.0.4-fix-buildsystem.patch36
-rw-r--r--app-text/o3read/o3read-0.0.4.ebuild18
2 files changed, 43 insertions, 11 deletions
diff --git a/app-text/o3read/files/o3read-0.0.4-fix-buildsystem.patch b/app-text/o3read/files/o3read-0.0.4-fix-buildsystem.patch
new file mode 100644
index 000000000000..63dcf95c0def
--- /dev/null
+++ b/app-text/o3read/files/o3read-0.0.4-fix-buildsystem.patch
@@ -0,0 +1,36 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,8 +2,6 @@
+ PACKAGE = o3read
+ VERSION = 0.0.4
+
+-CC = gcc
+-CFLAGS = -Wall -ansi -pedantic -O -g
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ MANDIR = $(PREFIX)/man/man1
+@@ -16,20 +14,13 @@
+
+ all: $(BINS)
+
+-utf8tolatin1: utf8tolatin1.o
+- $(CC) -o utf8tolatin1 utf8tolatin1.o
++o3totxt: o3read.o
+
+-o3totxt: o3totxt.o o3read.o
+- $(CC) -o o3totxt o3totxt.o o3read.o
++o3tohtml: o3read.o
+
+-o3tohtml: o3tohtml.o o3read.o
+- $(CC) -o o3tohtml o3tohtml.o o3read.o
++o3tosiag: o3read.o
+
+-o3tosiag: o3tosiag.o o3read.o
+- $(CC) -o o3tosiag o3tosiag.o o3read.o
+-
+-o3read: main.o o3read.o
+- $(CC) -o o3read main.o o3read.o
++o3read: main.o
+
+ dist:
+ rm -rf $(PACKAGE)-$(VERSION)
diff --git a/app-text/o3read/o3read-0.0.4.ebuild b/app-text/o3read/o3read-0.0.4.ebuild
index 9b39421c0634..4cf54987a0c9 100644
--- a/app-text/o3read/o3read-0.0.4.ebuild
+++ b/app-text/o3read/o3read-0.0.4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
inherit toolchain-funcs
@@ -12,20 +12,16 @@ SRC_URI="http://siag.nu/pub/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
+RESTRICT="test"
-RESTRICT=test
+PATCHES=( "${FILESDIR}"/${P}-fix-buildsystem.patch )
-src_prepare() {
- sed \
- -e 's:-o:$(LDFLAGS) -o:g' \
- -e '/^CC/d' \
- -e '/^CFLAGS/g' \
- -i Makefile || die
+src_configure() {
tc-export CC
}
src_install() {
dobin o3read o3totxt o3tohtml utf8tolatin1
- doman o3read.1 o3tohtml.1 o3totxt.1 utf8tolatin1.1
+ einstalldocs
+ doman *.1
}