summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/openjade/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/openjade/files')
-rw-r--r--app-text/openjade/files/openjade-1.3.2-acinclude.m461
-rw-r--r--app-text/openjade/files/openjade-1.3.2-darwin.patch41
-rw-r--r--app-text/openjade/files/openjade-1.3.2-deplibs.patch40
-rw-r--r--app-text/openjade/files/openjade-1.3.2-gcc46.patch74
-rw-r--r--app-text/openjade/files/openjade-1.3.2-ldflags.patch13
-rw-r--r--app-text/openjade/files/openjade-1.3.2-libosp-la.patch38
-rw-r--r--app-text/openjade/files/openjade-1.3.2-msggen.pl.patch32
-rw-r--r--app-text/openjade/files/openjade-1.3.2-respect-ldflags.patch12
-rw-r--r--app-text/openjade/files/openjade-1.3.2.dsssl-catalog4
9 files changed, 315 insertions, 0 deletions
diff --git a/app-text/openjade/files/openjade-1.3.2-acinclude.m4 b/app-text/openjade/files/openjade-1.3.2-acinclude.m4
new file mode 100644
index 000000000000..7bb6d2cb1f81
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-acinclude.m4
@@ -0,0 +1,61 @@
+dnl Configure-time switch with default
+dnl
+dnl Each switch defines an --enable-FOO and --disable-FOO option in
+dnl the resulting configure script.
+dnl
+dnl Usage:
+dnl smr_SWITCH(name, description, default, pos-def, neg-def)
+dnl
+dnl where:
+dnl
+dnl name name of switch; generates --enable-name & --disable-name
+dnl options
+dnl description help string is set to this prefixed by "enable" or
+dnl "disable", whichever is the non-default value
+dnl default either "on" or "off"; specifies default if neither
+dnl --enable-name nor --disable-name is specified
+dnl pos-def a symbol to AC_DEFINE if switch is on (optional)
+dnl neg-def a symbol to AC_DEFINE if switch is off (optional)
+dnl
+AC_DEFUN(smr_SWITCH, [
+ AC_MSG_CHECKING(whether to enable $2)
+ AC_ARG_ENABLE(
+ $1,
+ ifelse($3, on,
+ [ --disable-[$1] disable [$2]],
+ [ --enable-[$1] enable [$2]]),
+ [ if test "$enableval" = yes; then
+ AC_MSG_RESULT(yes)
+ ifelse($4, , , AC_DEFINE($4))
+ else
+ AC_MSG_RESULT(no)
+ ifelse($5, , , AC_DEFINE($5))
+ fi ],
+ ifelse($3, on,
+ [ AC_MSG_RESULT(yes)
+ ifelse($4, , , AC_DEFINE($4)) ],
+ [ AC_MSG_RESULT(no)
+ ifelse($5, , , AC_DEFINE($5))]))])
+
+dnl
+dnl Examine size_t and define SIZE_T_IS_UINT, if size_t is an unsigned int
+dnl
+AC_DEFUN(OJ_SIZE_T_IS_UINT,[
+ AC_REQUIRE([AC_TYPE_SIZE_T])
+ AC_MSG_CHECKING(whether size_t is unsigned int)
+ ac_cv_size_t_is_uint=no
+ AC_LANG_SAVE
+ AC_LANG_CPLUSPLUS
+ AC_TRY_COMPILE([#include <unistd.h>
+
+ template<class T> class foo { };
+
+ ], [
+ foo<size_t> x;
+ foo<unsigned int> y;
+ x = y;
+ ],ac_cv_size_t_is_uint=yes)
+ AC_LANG_RESTORE
+ AC_MSG_RESULT($ac_cv_size_t_is_uint)
+ test "$ac_cv_size_t_is_uint" = "yes" && AC_DEFINE(SIZE_T_IS_UINT)
+])
diff --git a/app-text/openjade/files/openjade-1.3.2-darwin.patch b/app-text/openjade/files/openjade-1.3.2-darwin.patch
new file mode 100644
index 000000000000..524454860d80
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-darwin.patch
@@ -0,0 +1,41 @@
+See also http://finkproject.org/doc/porting/libtool.php
+(Section 3.3) Fixing 1.4.x (Subsection 1) The flat_namespace bug
+--- configure~ 2007-10-08 01:55:00 +0200
++++ configure 2007-10-08 01:55:27 +0200
+@@ -3063,9 +3063,6 @@
+
+
+ case "${host}" in
+- *-*-darwin*)
+- LINKFLAGS="-no-undefined"
+- ;;
+ *)
+ if test "$GXX"
+ then
+@@ -7907,7 +7904,7 @@
+ ;;
+
+ darwin* | rhapsody*)
+- allow_undefined_flag='-undefined suppress'
++ allow_undefined_flag='-undefined suppress -flat_namespace'
+ # FIXME: Relying on posixy $() will cause problems for
+ # cross-compilation, but unfortunately the echo tests do not
+ # yet detect zsh echo's removal of \ escapes.
+--- config/ltmain.sh~ 2002-01-17 14:45:52 +0100
++++ config/ltmain.sh 2007-10-08 03:08:26 +0200
+@@ -3913,10 +3913,15 @@
+
+ # Directory that this library needs to be installed in:
+ libdir='$install_libdir'"
++case "${host}" in
++ *-*-darwin*)
++ ;;
++ *)
+ if test "$installed" = no && test $need_relink = yes; then
+ $echo >> $output "\
+ relink_command=\"$relink_command\""
+ fi
++esac
+ done
+ fi
+
diff --git a/app-text/openjade/files/openjade-1.3.2-deplibs.patch b/app-text/openjade/files/openjade-1.3.2-deplibs.patch
new file mode 100644
index 000000000000..3466ad7d85e3
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-deplibs.patch
@@ -0,0 +1,40 @@
+diff -urNp openjade-1.3.2/grove/Makefile.sub devel/grove/Makefile.sub
+--- openjade-1.3.2/grove/Makefile.sub 2002-10-20 23:47:24.000000000 +0200
++++ devel/grove/Makefile.sub 2007-07-23 15:39:23.000000000 +0200
+@@ -1,4 +1,4 @@
+ LTVERSION=0:1:0
+ LIB=ogrove
+-DEPLIBS=-lm
++DEPLIBS=-lm -lstdc++
+ OBJS=Node.o LocNode.o
+diff -urNp openjade-1.3.2/spgrove/Makefile.sub devel/spgrove/Makefile.sub
+--- openjade-1.3.2/spgrove/Makefile.sub 2002-11-15 23:46:50.000000000 +0100
++++ devel/spgrove/Makefile.sub 2007-07-23 16:06:13.000000000 +0200
+@@ -1,9 +1,10 @@
+ LTVERSION=0:1:0
+ LIB=ospgrove
+ INCLUDE=-I$(srcdir)/../grove
+-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
++DEPLIBS=$(TOP)/grove/libogrove.la \
++ -lm -losp -L$(TOP)/grove/.libs \
+ -L$(TOP)/lib -L$(TOP)/lib/.libs \
+- $(LIB_THREADS)
++ $(LIB_THREADS) -lstdc++
+ OBJS=GroveApp.o GroveBuilder.o SdNode.o
+ GENSRCS=grove_inst.cxx
+
+diff -urNp openjade-1.3.2/style/Makefile.sub devel/style/Makefile.sub
+--- openjade-1.3.2/style/Makefile.sub 2003-04-18 19:18:10.000000000 +0200
++++ devel/style/Makefile.sub 2007-07-23 16:08:26.000000000 +0200
+@@ -1,8 +1,8 @@
+ LTVERSION=0:1:0
+ LIB=ostyle
+-DEPLIBS=-lm -L$(TOP)/grove -L$(TOP)/grove/.libs \
+- -L$(TOP)/lib -L$(TOP)/lib/.libs \
+- -L$(TOP)/spgrove -L$(TOP)/spgrove/.libs
++DEPLIBS=$(TOP)/grove/libogrove.la $(TOP)/spgrove/libospgrove.la \
++ -lm -losp -L$(TOP)/lib -L$(TOP)/lib/.libs -L$(TOP)/grove/.libs \
++ -L$(TOP)/spgrove -L$(TOP)/spgrove/.libs -lstdc++
+ OBJS=LangObj.o \
+ Collector.o \
+ DssslApp.o \
diff --git a/app-text/openjade/files/openjade-1.3.2-gcc46.patch b/app-text/openjade/files/openjade-1.3.2-gcc46.patch
new file mode 100644
index 000000000000..e947ffe12f7f
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-gcc46.patch
@@ -0,0 +1,74 @@
+--- openjade-1.3.2-orig//jade/TeXFOTBuilder.cxx 2011-05-02 22:08:49.274006803 +0000
++++ openjade-1.3.2-orig//jade/TeXFOTBuilder.cxx 2011-05-02 22:14:09.849006939 +0000
+@@ -88,6 +88,8 @@
+ value.convertString(nic_.placement);
+ }
+ ExtensionFlowObj *copy() const { return new PageFloatFlowObj(*this); }
++ public:
++ PageFloatFlowObj() {}
+ private:
+ PageFloatNIC nic_;
+ StringC name_;
+@@ -101,6 +103,8 @@
+ fotb.endPageFootnote();
+ }
+ ExtensionFlowObj *copy() const { return new PageFootnoteFlowObj(*this); }
++ public:
++ PageFootnoteFlowObj() {}
+ private:
+ };
+ //////////////////////////////////////////////////////////////////////
+--- openjade-1.3.2-orig//jade/TransformFOTBuilder.cxx 2011-05-02 22:08:49.275006803 +0000
++++ openjade-1.3.2-orig//jade/TransformFOTBuilder.cxx 2011-05-02 22:18:31.614007052 +0000
+@@ -41,6 +41,7 @@
+ };
+ class EntityRefFlowObj : public TransformExtensionFlowObj {
+ public:
++ EntityRefFlowObj() {}
+ void atomic(TransformFOTBuilder &fotb, const NodePtr &) const {
+ fotb.entityRef(name_);
+ }
+@@ -56,6 +57,7 @@
+ };
+ class ProcessingInstructionFlowObj : public TransformExtensionFlowObj {
+ public:
++ ProcessingInstructionFlowObj() {}
+ void atomic(TransformFOTBuilder &fotb, const NodePtr &) const {
+ fotb.processingInstruction(data_);
+ }
+@@ -98,6 +100,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new EmptyElementFlowObj(*this); }
++ public:
++ EmptyElementFlowObj() {}
+ private:
+ ElementNIC nic_;
+ };
+@@ -133,6 +137,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new ElementFlowObj(*this); }
++ public:
++ ElementFlowObj() {}
+ private:
+ ElementNIC nic_;
+ };
+@@ -150,6 +156,8 @@
+ value.convertString(systemId_);
+ }
+ ExtensionFlowObj *copy() const { return new EntityFlowObj(*this); }
++ public:
++ EntityFlowObj() {};
+ private:
+ StringC systemId_;
+ };
+@@ -174,6 +182,8 @@
+ }
+ }
+ ExtensionFlowObj *copy() const { return new DocumentTypeFlowObj(*this); }
++ public:
++ DocumentTypeFlowObj() {}
+ private:
+ DocumentTypeNIC nic_;
+ };
diff --git a/app-text/openjade/files/openjade-1.3.2-ldflags.patch b/app-text/openjade/files/openjade-1.3.2-ldflags.patch
new file mode 100644
index 000000000000..4ddd4d414854
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-ldflags.patch
@@ -0,0 +1,13 @@
+Index: openjade-1.3.2/jade/Makefile.sub
+===================================================================
+--- openjade-1.3.2.orig/jade/Makefile.sub
++++ openjade-1.3.2/jade/Makefile.sub
+@@ -4,7 +4,7 @@ OBJS=jade.o SgmlFOTBuilder.o RtfFOTBuild
+ INCLUDE=-I$(srcdir)/../grove -I$(srcdir)/../spgrove -I$(srcdir)/../style
+ # XLIBS=../style/libostyle.a ../spgrove/libospgrove.a ../grove/libogrove.a \
+ # ../lib/libosp.a
+-XLIBS=../style/libostyle.a ../spgrove/libospgrove.a ../grove/libogrove.a $(splibdir)/libosp.a
++XLIBS=../style/libostyle.a ../grove/libogrove.a ../spgrove/libospgrove.a $(splibdir)/libosp.a
+ GENSRCS=JadeMessages.h HtmlMessages.h RtfMessages.h TeXMessages.h \
+ HtmlFOTBuilder_inst.cxx RtfFOTBuilder_inst.cxx TeXFOTBuilder_inst.cxx \
+ TransformFOTBuilder_inst.cxx MifMessages.h MifFOTBuilder_inst.cxx
diff --git a/app-text/openjade/files/openjade-1.3.2-libosp-la.patch b/app-text/openjade/files/openjade-1.3.2-libosp-la.patch
new file mode 100644
index 000000000000..d106771b599d
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-libosp-la.patch
@@ -0,0 +1,38 @@
+diff -u /var/tmp/portage/app-text/openjade-1.3.2-r1/work/openjade-1.3.2/jade/Makefile.sub /tmp/buffer-content-5978gFR
+--- a/jade/Makefile.sub 2009-11-19 17:21:46.000000000 -0500
++++ b/jade/Makefile.sub 2009-11-19 17:23:24.000000000 -0500
+@@ -4,7 +4,8 @@
+ INCLUDE=-I$(srcdir)/../grove -I$(srcdir)/../spgrove -I$(srcdir)/../style
+ # XLIBS=../style/libostyle.a ../spgrove/libospgrove.a ../grove/libogrove.a \
+ # ../lib/libosp.a
+-XLIBS=../style/libostyle.a ../grove/libogrove.a ../spgrove/libospgrove.a $(splibdir)/libosp.a
++XLIBS=../style/libostyle.a ../grove/libogrove.a ../spgrove/libospgrove.a -losp
++EXT_LIBS=-L$(splibdir) -losp $(LIBS)
+ GENSRCS=JadeMessages.h HtmlMessages.h RtfMessages.h TeXMessages.h \
+ HtmlFOTBuilder_inst.cxx RtfFOTBuilder_inst.cxx TeXFOTBuilder_inst.cxx \
+ TransformFOTBuilder_inst.cxx MifMessages.h MifFOTBuilder_inst.cxx
+
+
+diff -u /var/tmp/portage/app-text/openjade-1.3.2-r1/work/openjade-1.3.2/Makefile.prog.in /tmp/buffer-content-5978T7K
+--- a/Makefile.prog.in 2002-01-22 06:57:53.000000000 -0500
++++ b/Makefile.prog.in 2009-11-19 17:23:05.000000000 -0500
+@@ -10,16 +10,15 @@
+ top_builddir=@TOP@
+ LINKFLAGS = @LINKFLAGS@
+
+-ALL_LIBS = $(XLIBS) $(LIBS)
+ Makefile.lt:
+- echo 'LT_LIBS='`echo $(ALL_LIBS)|sed 's/\.a/.la/g'` >Makefile.lt
++ echo 'LT_LIBS='`echo $(XLIBS)|sed 's/\.a/.la/g'` >Makefile.lt
+
+ PROG:=$(shell echo "$(PROG)" | sed '@program_transform_name@')
+
+ all: $(PROG)
+
+ $(PROG): $(OBJS) $(COBJS) $(LT_LIBS)
+- $(LIBTOOL) --mode=link $(CXX) $(LINKFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(COBJS) $(LT_LIBS)
++ $(LIBTOOL) --mode=link $(CXX) $(LINKFLAGS) $(CXXFLAGS) $(LDFLAGS) -o $@ $(OBJS) $(COBJS) $(LT_LIBS) $(EXT_LIBS)
+
+ install: $(PROG)
+ -test -d $(DESTDIR)$(bindir) || \
+
diff --git a/app-text/openjade/files/openjade-1.3.2-msggen.pl.patch b/app-text/openjade/files/openjade-1.3.2-msggen.pl.patch
new file mode 100644
index 000000000000..1afe68b800e9
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-msggen.pl.patch
@@ -0,0 +1,32 @@
+Use Getopt::Std in place of getopts.pl.
+https://bugs.gentoo.org/show_bug.cgi?id=420083
+
+--- a/msggen.pl
++++ b/msggen.pl
+@@ -4,6 +4,7 @@
+ # See the file COPYING for copying permission.
+
+ use POSIX;
++use Getopt::Std;
+
+ # Package and version.
+ $package = 'openjade';
+@@ -18,8 +19,7 @@
+ undef $opt_l;
+ undef $opt_p;
+ undef $opt_t;
+-do 'getopts.pl';
+-&Getopts('l:p:t:');
++getopts('l:p:t:');
+ $module = $opt_l;
+ $pot_file = $opt_p;
+
+@@ -72,7 +72,7 @@
+ else {
+ $field[0] =~ /^[IWQXE][0-9]$/ || &error("invalid first field");;
+ $type[$num] = substr($field[0], 0, 1);
+- $argc = int(substr($field[0], 1, 1));
++ $argc = substr($field[0], 1, 1);
+ }
+ $nargs[$num] = $argc;
+ $field[1] =~ /^[a-zA-Z_][a-zA-Z0-9_]+$/ || &error("invalid tag");
diff --git a/app-text/openjade/files/openjade-1.3.2-respect-ldflags.patch b/app-text/openjade/files/openjade-1.3.2-respect-ldflags.patch
new file mode 100644
index 000000000000..51bd0b27dd42
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2-respect-ldflags.patch
@@ -0,0 +1,12 @@
+diff -ru a/Makefile.lib.in b/Makefile.lib.in
+--- a/Makefile.lib.in 2002-01-22 05:57:53.000000000 -0600
++++ b/Makefile.lib.in 2009-01-04 16:15:41.000000000 -0600
+@@ -23,7 +23,7 @@
+ echo 'LT_OBJS='`echo $(OBJS)|sed 's/\.o/.lo/g'` >Makefile.lt
+
+ lib$(LIB).la: $(LT_OBJS)
+- $(LIBTOOL) --mode=link $(CC) $(LINKFLAGS) -o lib$(LIB).la $(LT_OBJS) \
++ $(LIBTOOL) --mode=link $(CC) $(LDFLAGS) $(LINKFLAGS) -o lib$(LIB).la $(LT_OBJS) \
+ -rpath $(libdir) -version-info $(LTVERSION) $(DEPLIBS)
+
+ install:
diff --git a/app-text/openjade/files/openjade-1.3.2.dsssl-catalog b/app-text/openjade/files/openjade-1.3.2.dsssl-catalog
new file mode 100644
index 000000000000..11bc0425afe0
--- /dev/null
+++ b/app-text/openjade/files/openjade-1.3.2.dsssl-catalog
@@ -0,0 +1,4 @@
+PUBLIC "-//James Clark//DTD DSSSL Flow Object Tree//EN" "fot.dtd"
+PUBLIC "ISO/IEC 10179:1996//DTD DSSSL Architecture//EN" "dsssl.dtd"
+PUBLIC "-//James Clark//DTD DSSSL Style Sheet//EN" "style-sheet.dtd"
+PUBLIC "-//OpenJade//DTD DSSSL Style Sheet//EN" "style-sheet.dtd"