summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-16 19:36:47 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-16 19:40:35 +0200
commit9143778ae06adcc728f491ededbd25694da18a2b (patch)
tree2a64777118b340a00ca79c02f31c656815edbfda /app-text/par/par-1.52-r1.ebuild
parentsys-apps/portage: Drop py3.3 from PYTHON_COMPAT (diff)
downloadgentoo-9143778ae06adcc728f491ededbd25694da18a2b.tar.gz
gentoo-9143778ae06adcc728f491ededbd25694da18a2b.tar.bz2
gentoo-9143778ae06adcc728f491ededbd25694da18a2b.zip
app-text/par: EAPI bump 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-text/par/par-1.52-r1.ebuild')
-rw-r--r--app-text/par/par-1.52-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-text/par/par-1.52-r1.ebuild b/app-text/par/par-1.52-r1.ebuild
new file mode 100644
index 000000000000..7e6f9b7dcf6e
--- /dev/null
+++ b/app-text/par/par-1.52-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="Par${PV/./}"
+DESCRIPTION="a paragraph reformatter, vaguely similar to fmt, but better"
+HOMEPAGE="http://www.nicemice.net/par/"
+SRC_URI="http://www.nicemice.net/par/${MY_P/./}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+DEPEND="!dev-util/par
+ !app-arch/par"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ make -f protoMakefile CC="$(tc-getCC) -c $CFLAGS" \
+ LINK1="$(tc-getCC) $LDFLAGS" || die 'make failed'
+}
+
+src_install() {
+ newbin par par-format
+ doman par.1
+ dodoc releasenotes par.doc
+}