summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-02-04 18:06:19 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-02-04 18:11:55 -0600
commitbb5366dfd17230a3a59c21817dae863c39458886 (patch)
treefdf288522bde250f0eced9f5fa3dac8d2af63024 /app-text/pdf2djvu
parentdev-tex/biber: version bump. (diff)
downloadgentoo-bb5366dfd17230a3a59c21817dae863c39458886.tar.gz
gentoo-bb5366dfd17230a3a59c21817dae863c39458886.tar.bz2
gentoo-bb5366dfd17230a3a59c21817dae863c39458886.zip
app-text/pdf2djvu: Version bump to 0.9.8
Closes: https://bugs.gentoo.org/644798 Closes: https://bugs.gentoo.org/643130 Closes: https://bugs.gentoo.org/634728 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'app-text/pdf2djvu')
-rw-r--r--app-text/pdf2djvu/Manifest1
-rw-r--r--app-text/pdf2djvu/pdf2djvu-0.9.8.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-text/pdf2djvu/Manifest b/app-text/pdf2djvu/Manifest
index 0a3fbc154d5f..0068663b291f 100644
--- a/app-text/pdf2djvu/Manifest
+++ b/app-text/pdf2djvu/Manifest
@@ -1,2 +1,3 @@
DIST pdf2djvu-0.9.3.tar.xz 239492 BLAKE2B e231f833075739e19a3dfe469eaa9f5eabf8b096473e9ea4d0dbbb296c33767cb612976f69548fd97966084cffeacc7f24230c789c6fbe5f1efed09988221b84 SHA512 388b76642c354480674b6eee4961792c4ef483313ffd25a6248d1d6302985ac5adfb558ae9241062893a419463c9626d8dac9d08297d66b68a98cebbcc4dc193
DIST pdf2djvu-0.9.4.tar.xz 250332 BLAKE2B 529c871216cb4ddc55560875b5c4d5a9aeb680140821c6d6d5ab71853a09f3661cfbf28ac4602d6d782afb682a14af8241d70cb82ca617f28a0752f45c852df7 SHA512 6b97d0577ee6e623d8c877393f551dd2a5e19508e5cd6dc5bb2d3ae1a2b71c2f0ffc7020d85507bc52a25da09a301dd5ddf45ab2628928477e0846707ea57322
+DIST pdf2djvu-0.9.8.tar.xz 268976 BLAKE2B 318ef4fd5677056d2404d769bf54911c9474d6f0f839ef472e121375ee268db31ddaaad2b8ed791ef093d6cb1c665f6431619918ee852e479b4a11a3d7ae0e23 SHA512 5f5330d3d15808b5b6233a15a984d0ebf28619cfb50807a20c8992fed68d17f73d1edd62b1ad7cd3a09d526f6c9f0827e2c5e03d6d7c8ad92c1f106755025f5e
diff --git a/app-text/pdf2djvu/pdf2djvu-0.9.8.ebuild b/app-text/pdf2djvu/pdf2djvu-0.9.8.ebuild
new file mode 100644
index 000000000000..d59dccb4f538
--- /dev/null
+++ b/app-text/pdf2djvu/pdf2djvu-0.9.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1 toolchain-funcs flag-o-matic
+
+DESCRIPTION="A tool to create DjVu files from PDF files"
+HOMEPAGE="http://jwilk.net/software/pdf2djvu"
+SRC_URI="https://github.com/jwilk/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+graphicsmagick nls openmp test"
+
+RDEPEND="
+ >=app-text/djvu-3.5.21:=
+ >=app-text/poppler-0.16.7:=
+ dev-libs/libxml2:=
+ dev-libs/libxslt:=
+ graphicsmagick? ( media-gfx/graphicsmagick:= )
+"
+DEPEND="${RDEPEND}
+ dev-cpp/pstreams
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep 'dev-python/nose[${PYTHON_USEDEP}]')
+ )
+"
+
+REQUIRED_USE="test? ( graphicsmagick ${PYTHON_REQUIRED_USE} )"
+
+DOCS=(
+ doc/{changelog,credits,djvudigital,README}
+)
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ # bug 626874, poppler headers require C++11
+ append-cxxflags -std=c++11
+ default
+}
+
+src_configure() {
+ local openmp=--disable-openmp
+ use openmp && tc-has-openmp && openmp=--enable-openmp
+
+ econf \
+ ${openmp} \
+ $(use_enable nls) \
+ $(use_with graphicsmagick)
+}