summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-03 15:03:15 +0000
committerSam James <sam@gentoo.org>2020-12-03 15:07:11 +0000
commite047ecc78e2e8ba48f0a178b80d60e0368cdbee4 (patch)
treef232c5fef1a0f0f8a8e46dc573287b684c235728 /app-text/pelican
parentprofiles/arch/riscv: mask rsh use (diff)
downloadgentoo-e047ecc78e2e8ba48f0a178b80d60e0368cdbee4.tar.gz
gentoo-e047ecc78e2e8ba48f0a178b80d60e0368cdbee4.tar.bz2
gentoo-e047ecc78e2e8ba48f0a178b80d60e0368cdbee4.zip
app-text/pelican: bump to 4.5.3
Bug: https://bugs.gentoo.org/758281 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/pelican')
-rw-r--r--app-text/pelican/Manifest1
-rw-r--r--app-text/pelican/pelican-4.5.3.ebuild50
-rw-r--r--app-text/pelican/pelican-9999.ebuild27
3 files changed, 61 insertions, 17 deletions
diff --git a/app-text/pelican/Manifest b/app-text/pelican/Manifest
index c3c010c88f64..733277c2ae06 100644
--- a/app-text/pelican/Manifest
+++ b/app-text/pelican/Manifest
@@ -1,2 +1,3 @@
DIST pelican-4.2.0.tar.gz 1332348 BLAKE2B 879a9d51f2b2956e895302dd613c877ff65bf8d420cd70144618ada07723037bca680f6983bdf3860d144ebae4eca8198219dad9caf0d6ecc06745a3881447fa SHA512 9c9f41306739acc4c6c6a7ddf50d955d958af7be1da197b42859b95405b18ab5b597fee4f9aabdf98cd508204558bff9c4f0c11bf4e5367b16e32568682a21e6
DIST pelican-4.5.1.tar.gz 1397023 BLAKE2B f12b16045feaf001c8f6e57116fb8e807ce1d51f16bf7a373203edec3d1edb91a2386dbf8fb008efbc11654ae1cbe678b4a3cbf99349340db1d784962e81ab5b SHA512 cb27399d3c280981d1e8cd01dbfd54b1a8bd11d9b87c4717226a2a467d73c3ad4e038a8e544534289a73e9e3cc64b4414e2b3bbf2cdd05b917d02df79ab40b5a
+DIST pelican-4.5.3.tar.gz 1397896 BLAKE2B 86651f627af67c571ea65a7ddfe7b62747fd2798575d6c4f29455da9b2371ce22ff42d715f148925724764e0a9fbb8aeba1dea401226856d3681b520dbb0a7af SHA512 b1ef5f145b448f6af2e25a1adb399521d4c5f7eef3ee2aa5ab9e50c223623b5c9961622e5cd835a3cb72dbbe905da6ac9217128f2459a35892bbac9b9cb6d26a
diff --git a/app-text/pelican/pelican-4.5.3.ebuild b/app-text/pelican/pelican-4.5.3.ebuild
new file mode 100644
index 000000000000..3b4f480c8e0e
--- /dev/null
+++ b/app-text/pelican/pelican-4.5.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A tool to generate a static blog, with restructured text or markdown input files"
+HOMEPAGE="https://blog.getpelican.com/ https://pypi.org/project/pelican/"
+SRC_URI="https://github.com/getpelican/pelican/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples markdown"
+
+RESTRICT="test"
+RDEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.7[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unidecode[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+DEPEND="test? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+
+DOCS=( README.rst )
+
+distutils_enable_tests nose
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples; then
+ insinto "/usr/share/doc/${PF}"
+ docompress -x "/usr/share/doc/${PF}/samples"
+ doins -r samples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/app-text/pelican/pelican-9999.ebuild b/app-text/pelican/pelican-9999.ebuild
index cda70ce55f5a..5ef3211ca690 100644
--- a/app-text/pelican/pelican-9999.ebuild
+++ b/app-text/pelican/pelican-9999.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python{3_6,3_7} )
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 git-r3
@@ -13,12 +15,10 @@ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
LICENSE="AGPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="doc examples markdown test"
-# Tests fail for this release but are fixed upstream
-RESTRICT="test"
+IUSE="doc examples markdown"
-DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
+RESTRICT="test"
+RDEPEND=">=dev-python/feedgenerator-1.9[${PYTHON_USEDEP}]
>=dev-python/jinja-2.7[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
@@ -28,15 +28,12 @@ DEPEND=">=dev-python/feedgenerator-1.6[${PYTHON_USEDEP}]
>=dev-python/six-1.4[${PYTHON_USEDEP}]
dev-python/python-dateutil[${PYTHON_USEDEP}]
doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- )"
-RDEPEND=""
-
+ markdown? ( dev-python/markdown[${PYTHON_USEDEP}] )"
+DEPEND="test? ( dev-python/markdown[${PYTHON_USEDEP}] )"
DOCS=( README.rst )
+distutils_enable_tests nose
+
python_compile_all() {
use doc && emake -C docs html
}
@@ -50,7 +47,3 @@ python_install_all() {
fi
distutils-r1_python_install_all
}
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}