summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-09-18 22:35:56 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-09-18 22:35:56 +0900
commitd3aa440dec9fc7be5028f0e06587566b4d3933c2 (patch)
tree82d49d0050cd140910294823843d890c186553a6 /app-text/po4a
parentnet-dns/dnscrypt-proxy: x86 stable wrt bug #813162 (diff)
downloadgentoo-d3aa440dec9fc7be5028f0e06587566b4d3933c2.tar.gz
gentoo-d3aa440dec9fc7be5028f0e06587566b4d3933c2.tar.bz2
gentoo-d3aa440dec9fc7be5028f0e06587566b4d3933c2.zip
app-text/po4a: new upstream release
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-text/po4a')
-rw-r--r--app-text/po4a/Manifest1
-rw-r--r--app-text/po4a/po4a-0.64.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/po4a/Manifest b/app-text/po4a/Manifest
index acbde749fbab..06ce61ac8511 100644
--- a/app-text/po4a/Manifest
+++ b/app-text/po4a/Manifest
@@ -1,3 +1,4 @@
DIST po4a-0.57.tar.gz 3079550 BLAKE2B 54b1d3263aa0ebd90eec61d735c3422efb5f67b2d88f91a87a6893bcdb7f06131aedadeb3577d221cf75ba07f8001f6e23409375756afec8357e26e8f0f0a1c2 SHA512 7ac2e614c126b049feeb8edbafb71a875cee78fb85d8cd74f3bf5b555cc8b2d19d5e4606b732e714e937c34e178729d73edfe559de594c5ffe811b5162b27d81
DIST po4a-0.62.tar.gz 3980028 BLAKE2B 4336c09254728b6a8d9c1220628612735e10d1531e3473eb7606900b9f20db3cfec1bb1c1c57f5c40bf8fce84fe823d25c743e2d50b3c56558239526f12bf09a SHA512 a91a31d9d80bb48ee071f39148572a4ec2b65f472a26696aa517c9d52ad56accf9fbdf971dcf15dd1c492cca7efab328ebffe1f20e98f7fe2532d4bf490a9997
DIST po4a-0.63.tar.gz 4067940 BLAKE2B 4cfa4163c21f5f8b783a5bdc29595f10cd172f7813de5617ed67a25bef547697084511a6f3897c47acb9158f15b3fcd97600bec7e23ba560cffe7cc646ce4c39 SHA512 556859b73728249795df22676a3cde1cbf575c608ad20f267fe7a6ee224d0262db2db19df8b7369ebf1ab568c017548ff118ae035608cca7a4d0963db8acd633
+DIST po4a-0.64.tar.gz 4121565 BLAKE2B a579aabb4245501be4ec7c319e8cef91db2e10883a09ef5a7eaf2d97aad64e8e59f25101c20286c955067fef2f58bc08c9865d5d608dd72913a38eaaff0ac542 SHA512 3d51aaa5894365087523b82e218819ba8a92d3cbc1b389648526f26fbbf37ccaa7ed6643bb388e5fa73a7a1abadee2b4ee2ebbcac14790c56567bf1a3e766fb0
diff --git a/app-text/po4a/po4a-0.64.ebuild b/app-text/po4a/po4a-0.64.ebuild
new file mode 100644
index 000000000000..d1d6f4f2dc65
--- /dev/null
+++ b/app-text/po4a/po4a-0.64.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PLOCALES="ace af ar ca cs da de eo es et eu fr hr hu id it ja kn ko nb nl pl pt pt_BR ru sl sr_Cyrl sv uk vi zh_CN zh_HK zh_Hant"
+
+inherit perl-module plocale
+
+DESCRIPTION="Tools to ease the translation of documentation"
+HOMEPAGE="https://po4a.org/"
+SRC_URI="https://github.com/mquinson/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/opensp
+ dev-libs/libxslt
+ dev-perl/Locale-gettext
+ dev-perl/Pod-Parser
+ dev-perl/SGMLSpm
+ dev-perl/TermReadKey
+ dev-perl/Text-WrapI18N
+ dev-perl/Unicode-LineBreak
+ dev-perl/YAML-Tiny
+ sys-devel/gettext"
+DEPEND="${RDEPEND}"
+BDEPEND="app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xsl-stylesheets
+ dev-perl/Module-Build
+ test? (
+ app-text/docbook-sgml-dtd:4.1
+ dev-perl/Test-Pod
+ virtual/latex-base
+ )"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.60-man.patch )
+
+DIST_TEST="do"
+
+src_prepare() {
+ plocale_find_changes "${S}/po/bin" '' '.po'
+
+ rm_locale() {
+ PERL_RM_FILES+=( po/{bin,pod}/${1}.po )
+ }
+ plocale_for_each_disabled_locale rm_locale
+
+ perl-module_src_prepare
+}