summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-11-11 21:39:25 -0800
committerZac Medico <zmedico@gentoo.org>2017-11-11 22:11:56 -0800
commit1e56f90e6115285729c9611152611a5f52962245 (patch)
tree944b953c35d417784ce4ad131b77a333ef4e4a41 /app-text/podofo
parentdev-python/PyQt5: version bump (diff)
downloadgentoo-1e56f90e6115285729c9611152611a5f52962245.tar.gz
gentoo-1e56f90e6115285729c9611152611a5f52962245.tar.bz2
gentoo-1e56f90e6115285729c9611152611a5f52962245.zip
app-text/podofo: version bump to 0.9.6_pre20171027
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'app-text/podofo')
-rw-r--r--app-text/podofo/Manifest1
-rw-r--r--app-text/podofo/podofo-0.9.6_pre20171027.ebuild143
2 files changed, 144 insertions, 0 deletions
diff --git a/app-text/podofo/Manifest b/app-text/podofo/Manifest
index 712ada504ac2..4b65f5793f2e 100644
--- a/app-text/podofo/Manifest
+++ b/app-text/podofo/Manifest
@@ -1,2 +1,3 @@
DIST podofo-0.9.6_pre20170508.tar.xz 919876 SHA256 6a35e08aa22105eeb6b00078b74791da2d4dc0d86189f795315808428efacd17 SHA512 37d8e844ba5763d06d467e316871436e1a63795d66675677d9775cd1bd311f43b241d58e82213a0342ab69a0f5cd80261aad48c4af29c82f7bcc0c14bd242f10 WHIRLPOOL c0ad8baca1f912929d1b2dd2e783340aeeb50965136dcf2699407cb70ca058e20748ee8024739b913a1e2ddb317c72f5aed6074862c4360d339365764ac9c67a
DIST podofo-0.9.6_pre20170629.tar.xz 919076 SHA256 439c0bffed19275315075d5b0a2728453e7a8bee4480e1f23bca2ee4b02462d0 SHA512 29b0e28131ca9cadf19e5ec43df1c39e146ad8d35ad9f0bfa2dff1138e3448c3be95c6130ef8a19b7ad927b8e0c5a7890485f120d7f7da85e2b434e4a417d9bc WHIRLPOOL b8ecab404679f48ff611e543d375829a636f4026232a83ff2fe3f3ca42f1a5c2a589641d4c09b92b7b078026a6b4d95b172a764089729086f7001d3a4850b272
+DIST podofo-0.9.6_pre20171027.tar.xz 919504 SHA256 0eff17add2c44e8d609756fa735e7265178c6eb9cf30ec2d5b896d6de83e643d SHA512 db1ac836abd7be0d2cc3c27114c7134de9de8ba931a6a8265514fedefe3c6f06a24371f7a5425c8b7251fe7166bc27f07733cba878ad24c12651c8c051cac8be WHIRLPOOL 8f0dbe4ffba24f1c3aee7c9d2ea819e232d9a552d048d09192960dae448d25593ad340712e055410d13b661110c90a2d5b5a69e02bf5511f78ee7a5b347bdbf0
diff --git a/app-text/podofo/podofo-0.9.6_pre20171027.ebuild b/app-text/podofo/podofo-0.9.6_pre20171027.ebuild
new file mode 100644
index 000000000000..67a8f21dd4db
--- /dev/null
+++ b/app-text/podofo/podofo-0.9.6_pre20171027.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format"
+HOMEPAGE="https://sourceforge.net/projects/podofo/"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+boost idn libressl debug test +tools"
+REQUIRED_USE="test? ( tools )"
+
+RDEPEND="dev-lang/lua:=
+ idn? ( net-dns/libidn:= )
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ media-libs/fontconfig:=
+ media-libs/freetype:2=
+ virtual/jpeg:0=
+ media-libs/libpng:0=
+ media-libs/tiff:0=
+ sys-libs/zlib:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ boost? ( dev-util/boost-build )
+ test? ( dev-util/cppunit )"
+
+DOCS="AUTHORS ChangeLog TODO"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ local x sed_args
+
+ # The 0.9.6 ABI is not necessarily stable, so make PODOFO_SOVERSION
+ # equal to ${PV}.
+ sed -e 's|${PODOFO_VERSION_PATCH}|\0_'${PV##*_}'|' -i CMakeLists.txt || die
+
+ # bug 620934 - Disable linking with cppunit when possible, since it
+ # triggers errors with some older compilers.
+ use test || sed -e 's:^FIND_PACKAGE(CppUnit):#\0:' -i CMakeLists.txt || die
+
+ # bug 556962
+ sed -i -e 's|Decrypt( pEncryptedBuffer, nOutputLen, pDecryptedBuffer, m_lLen );|Decrypt( pEncryptedBuffer, (pdf_long)nOutputLen, pDecryptedBuffer, (pdf_long\&)m_lLen );|' \
+ test/unit/EncryptTest.cpp || die
+
+ sed -i \
+ -e "s:LIBDIRNAME \"lib\":LIBDIRNAME \"$(get_libdir)\":" \
+ -e "s:LIBIDN_FOUND:HAVE_LIBIDN:g" \
+ CMakeLists.txt || die
+
+ # Use pkg-config to find headers for bug #459404.
+ sed_args=
+ for x in $($(tc-getPKG_CONFIG) --cflags freetype2) ; do
+ [[ ${x} == -I* ]] || continue
+ x=${x#-I}
+ if [[ -f ${x}/ft2build.h ]] ; then
+ sed_args+=" -e s:/usr/include/\\r\$:${x}:"
+ elif [[ -f ${x}/freetype/config/ftheader.h ]] ; then
+ sed_args+=" -e s:/usr/include/freetype2\\r\$:${x}:"
+ fi
+ done
+ [[ -n ${sed_args} ]] && \
+ { sed -i ${sed_args} cmake/modules/FindFREETYPE.cmake || die; }
+
+ # Bug #439784: Add missing unistd include for close() and unlink().
+ sed -i 's:^#include <stdio.h>$:#include <unistd.h>\n\0:' -i \
+ test/unit/TestUtils.cpp || die
+
+ # TODO: fix these test cases
+ # ColorTest.cpp:62:Assertion
+ # Test name: ColorTest::testDefaultConstructor
+ # expected exception not thrown
+ # - Expected: PdfError
+ sed -e 's:CPPUNIT_TEST( testDefaultConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testGreyConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testRGBConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testCMYKConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorSeparationAllConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorSeparationNoneConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorSeparationConstructor ://\0:' \
+ -e 's:CPPUNIT_TEST( testColorCieLabConstructor ://\0:' \
+ -i test/unit/ColorTest.h || die
+
+ # ColorTest.cpp:42:Assertion
+ # Test name: ColorTest::testHexNames
+ # assertion failed
+ # - Expression: static_cast<int>(rgb.GetGreen() * 255.0) == 0x0A
+ sed -e 's:CPPUNIT_TEST( testHexNames ://\0:' \
+ -i test/unit/ColorTest.h || die
+
+ # Bug #352125: test failure, depending on installed fonts
+ # ##Failure Location unknown## : Error
+ # Test name: FontTest::testFonts
+ # uncaught exception of type PoDoFo::PdfError
+ # - ePdfError_UnsupportedFontFormat
+ sed -e 's:CPPUNIT_TEST( testFonts ://\0:' \
+ -i test/unit/FontTest.h || die
+
+ # Test name: EncodingTest::testDifferencesEncoding
+ # equality assertion failed
+ # - Expected: 1
+ # - Actual : 0
+ sed -e 's:CPPUNIT_TEST( testDifferencesEncoding ://\0:' \
+ -i test/unit/EncodingTest.h || die
+
+ # Bug #407015: fix to compile with Lua 5.2
+ if has_version '>=dev-lang/lua-5.2' ; then
+ sed -e 's: lua_open(: luaL_newstate(:' \
+ -e 's: luaL_getn(: lua_rawlen(:' -i \
+ tools/podofocolor/luaconverter.cpp \
+ tools/podofoimpose/planreader_lua.cpp || die
+ fi
+}
+
+src_configure() {
+
+ # Bug #381359: undefined reference to `PoDoFo::PdfVariant::DelayedLoadImpl()'
+ filter-flags -fvisibility-inlines-hidden
+
+ mycmakeargs+=(
+ "-DPODOFO_BUILD_SHARED=1"
+ "-DPODOFO_HAVE_JPEG_LIB=1"
+ "-DPODOFO_HAVE_PNG_LIB=1"
+ "-DPODOFO_HAVE_TIFF_LIB=1"
+ "-DWANT_FONTCONFIG=1"
+ "-DUSE_STLPORT=0"
+ -DWANT_BOOST=$(usex boost ON OFF)
+ -DHAVE_LIBIDN=$(usex idn ON OFF)
+ -DPODOFO_HAVE_CPPUNIT=$(usex test ON OFF)
+ -DPODOFO_BUILD_LIB_ONLY=$(usex tools OFF ON)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ cd "${CMAKE_BUILD_DIR}"/test/unit
+ ./podofo-test --selftest || die "self test failed"
+}