summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-19 21:01:59 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-19 21:02:46 +0100
commit5e72252f1d145dabbf0a78db1b00eb4824a07480 (patch)
treef7ea953473ef7632bb73a2bb392a4583e02b918f /app-text/poppler
parentdev-ruby/facter: fixing the separation of the leatherman dep (diff)
downloadgentoo-5e72252f1d145dabbf0a78db1b00eb4824a07480.tar.gz
gentoo-5e72252f1d145dabbf0a78db1b00eb4824a07480.tar.bz2
gentoo-5e72252f1d145dabbf0a78db1b00eb4824a07480.zip
app-text/poppler: Update live ebuild from 0.42.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text/poppler')
-rw-r--r--app-text/poppler/poppler-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index b10c1df28bc2..d7c5ef7461db 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
+CMAKE_WARN_UNUSED_CLI=1
inherit cmake-utils toolchain-funcs xdg-utils
if [[ "${PV}" == "9999" ]] ; then
@@ -13,14 +14,14 @@ if [[ "${PV}" == "9999" ]] ; then
else
SRC_URI="http://poppler.freedesktop.org/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
- SLOT="0/52" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+ SLOT="0/59" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
fi
DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
HOMEPAGE="http://poppler.freedesktop.org/"
LICENSE="GPL-2"
-IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms png qt4 qt5 tiff +utils"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt4 qt5 tiff +utils"
# No test data provided
RESTRICT="test"
@@ -38,6 +39,7 @@ COMMON_DEPEND="
jpeg? ( virtual/jpeg:0 )
jpeg2k? ( media-libs/openjpeg:2= )
lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
png? ( media-libs/libpng:0= )
qt4? (
dev-qt/qtcore:4
@@ -86,17 +88,22 @@ src_configure() {
-DBUILD_CPP_TESTS=OFF
-DENABLE_SPLASH=ON
-DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
-DENABLE_XPDF_HEADERS=ON
- $(cmake-utils_use_enable curl LIBCURL)
- $(cmake-utils_use_enable cxx CPP)
- $(cmake-utils_use_enable utils)
- $(cmake-utils_use_with cairo)
- $(cmake-utils_use_with introspection GObjectIntrospection)
- $(cmake-utils_use_with jpeg)
- $(cmake-utils_use_with png)
- $(cmake-utils_use_with qt4)
+ -DENABLE_LIBCURL="$(usex curl)"
+ -DENABLE_CPP="$(usex cxx)"
+ -DENABLE_UTILS="$(usex utils)"
+ -DSPLASH_CMYK=OFF
+ -DUSE_FIXEDPOINT=OFF
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo="$(usex cairo)"
+ -DWITH_GObjectIntrospection="$(usex introspection)"
+ -DWITH_JPEG="$(usex jpeg)"
+ -DWITH_NSS3="$(usex nss)"
+ -DWITH_PNG="$(usex png)"
+ -DWITH_Qt4="$(usex qt4)"
$(cmake-utils_use_find_package qt5 Qt5Core)
- $(cmake-utils_use_with tiff)
+ -DWITH_TIFF="$(usex tiff)"
)
if use jpeg2k; then
mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)