summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/ps2eps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/ps2eps')
-rw-r--r--app-text/ps2eps/Manifest1
-rw-r--r--app-text/ps2eps/metadata.xml14
-rw-r--r--app-text/ps2eps/ps2eps-1.68.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/app-text/ps2eps/Manifest b/app-text/ps2eps/Manifest
new file mode 100644
index 000000000000..2956a102ff50
--- /dev/null
+++ b/app-text/ps2eps/Manifest
@@ -0,0 +1 @@
+DIST ps2eps-1.68.tar.gz 97304 SHA256 b08f12eed88965d1891261fb70e87c7e3a3f3172ebc31bdb7994a7ce854dd925 SHA512 7fc84da5da00d5b1169d6e337b1db232adf80d9d957e48bfdd9272946151adca3e44f712587387ef557488cd15f44210b3fbd8c545488ec0071641d9d25a9c2b WHIRLPOOL 231f22ccfff1341ca9ac713254786028b422df9e805754b4631e6d73146413ccfc7ac9306433c45c63c3ad7499065f444580da8125a15a6120dae1c9cdc536ac
diff --git a/app-text/ps2eps/metadata.xml b/app-text/ps2eps/metadata.xml
new file mode 100644
index 000000000000..8c2230e6ced9
--- /dev/null
+++ b/app-text/ps2eps/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>printing</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ </maintainer>
+ <longdescription lang="en">
+ Tool for generating Encapsulated Postscript Format (EPS,EPSF) files
+ from one-page Postscript documents
+ </longdescription>
+</pkgmetadata>
+
diff --git a/app-text/ps2eps/ps2eps-1.68.ebuild b/app-text/ps2eps/ps2eps-1.68.ebuild
new file mode 100644
index 000000000000..28394703a4a1
--- /dev/null
+++ b/app-text/ps2eps/ps2eps-1.68.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Generate Encapsulated Postscript Format (EPS,EPSF) files from one-page Postscript documents"
+HOMEPAGE="http://www.tm.uka.de/~bless/ps2eps"
+SRC_URI="http://www.tm.uka.de/~bless/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="app-text/ghostscript-gpl
+ !<app-text/texlive-core-2007-r7"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ tc-export CC
+ cd "${S}/src/C"
+ echo "all: bbox" > Makefile
+ emake || die "making bbox failed"
+}
+
+src_install() {
+ dobin "${S}/src/C/bbox"
+ dobin "${S}/bin/ps2eps"
+ doman "${S}/doc/man/man1/bbox.1"
+ doman "${S}/doc/man/man1/ps2eps.1"
+
+ dodoc Changes.txt README.txt
+ dohtml "${S}/doc/html/"*
+ docinto pdf
+ dodoc "${S}/doc/pdf/"*
+}