summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-27 16:18:18 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-28 19:01:51 -0400
commit996c6460f292c32e3ba93c4cb713d1515edc1310 (patch)
tree58bf275673d266db337976341480b19fa662b7cc /app-text/pspresent
parentapp-misc/logserial: bump EAPI and drop eutils (diff)
downloadgentoo-996c6460f292c32e3ba93c4cb713d1515edc1310.tar.gz
gentoo-996c6460f292c32e3ba93c4cb713d1515edc1310.tar.bz2
gentoo-996c6460f292c32e3ba93c4cb713d1515edc1310.zip
app-text/pspresent: bump EAPI
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text/pspresent')
-rw-r--r--app-text/pspresent/pspresent-1.3-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-text/pspresent/pspresent-1.3-r1.ebuild b/app-text/pspresent/pspresent-1.3-r1.ebuild
index c13ed4cddafe..e1e20e29a0d2 100644
--- a/app-text/pspresent/pspresent-1.3-r1.ebuild
+++ b/app-text/pspresent/pspresent-1.3-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
inherit toolchain-funcs
@@ -22,6 +22,7 @@ DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_prepare() {
+ default
if ! use xinerama ; then
sed -i -e "/^XINERAMA/s/^/#/g" Makefile || die "sed Makefile"
fi
@@ -32,7 +33,7 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC) || die
+ emake CC=$(tc-getCC)
}
src_install() {