summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-06-24 14:21:26 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-06-24 14:22:00 -0700
commite2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2 (patch)
treeaaf6ad5208fdfa767df71364a732c3f530ba578b /app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild
parentapp-emulation/virtualbox: [QA] Remove $Id$ line from header. (diff)
downloadgentoo-e2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2.tar.gz
gentoo-e2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2.tar.bz2
gentoo-e2b549a82496d0f5c1daa29d9ea1b81ff0b68ec2.zip
app-text/q-text-as-data: bump, now with py3 support
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild')
-rw-r--r--app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild b/app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild
new file mode 100644
index 000000000000..f3c988259f1b
--- /dev/null
+++ b/app-text/q-text-as-data/q-text-as-data-2.0.10.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python2_7 python3_{6..9} )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-r1
+
+DESCRIPTION="A CLI tool that allows direct execution of SQL-like queries on text"
+HOMEPAGE="http://harelba.github.io/q/"
+MY_P="q-${PV}"
+SRC_URI="https://github.com/harelba/q/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# Upstream is wrong
+# http://harelba.github.io/q/#requirements
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_any_dep '
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/flake8[${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ : # Do not use the Makefile
+}
+
+q_install() {
+ python_newexe bin/q.py q-text-as-data
+}
+
+src_install() {
+ python_foreach_impl q_install
+ newdoc bin/.qrc dot-qrc
+ dodoc doc/*
+}
+
+pkg_postinst() {
+ einfo "On Gentoo, the 'q' binary is most often provided by app-portage/portage-utils;"
+ einfo "Thus, this tool is install as 'q-text-as-data' rather than 'q'."
+}