summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/refbase
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/refbase')
-rw-r--r--app-text/refbase/Manifest1
-rw-r--r--app-text/refbase/files/postinstall-en.txt22
-rw-r--r--app-text/refbase/metadata.xml8
-rw-r--r--app-text/refbase/refbase-0.9.5.ebuild41
4 files changed, 72 insertions, 0 deletions
diff --git a/app-text/refbase/Manifest b/app-text/refbase/Manifest
new file mode 100644
index 000000000000..02588ae1ab56
--- /dev/null
+++ b/app-text/refbase/Manifest
@@ -0,0 +1 @@
+DIST refbase-0.9.5.tar.gz 1395726 SHA256 b832ab7f0e8c0ded88c7210d5314be849491ea913b78486898ffb3535b4391eb SHA512 68022eee0c15a4e733a8eef8cd5ca15d6e29a4f3559539657c4a38733a4338b51ef4b716cfd964bdd5eb94dda3c7f012b6e01deb59879f3dbfd79d4d8ce11305 WHIRLPOOL f85609b99182d0fb7d16b39e900d857773136975624b110c6d9a23547682785e416d44797d15f0880b6f342fb30a1474ec362f95b40119202c4454f7168b6b20
diff --git a/app-text/refbase/files/postinstall-en.txt b/app-text/refbase/files/postinstall-en.txt
new file mode 100644
index 000000000000..1b28143032f9
--- /dev/null
+++ b/app-text/refbase/files/postinstall-en.txt
@@ -0,0 +1,22 @@
+You are almost done!
+
+ 1. Restart your webserver
+
+ 2. Open the file '${MY_INSTALLDIR}/initialize/db.inc.php'
+ in a text editor and edit the values of the variables '\$databaseName',
+ '\$username' and '\$password' to fit your needs.
+ (Note that you'll be able to use the refbase package without modifying
+ these variables, but we highly recommend not to use the default
+ values!)
+
+ 3. Now, open a web browser and access the 'install.php' script by typing:
+
+ <http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/install.php>
+
+ This should bring up the install form. Edit the contents of all text
+ entry fields to match your server setup and supply the MySQL admin
+ password, then click the 'Install' button to install the database.
+
+ 4. For further instructions, see /usr/share/doc/refbase-0.8.0/INSTALL.gz
+
+ Enjoy!
diff --git a/app-text/refbase/metadata.xml b/app-text/refbase/metadata.xml
new file mode 100644
index 000000000000..1dfe25bebf19
--- /dev/null
+++ b/app-text/refbase/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <upstream>
+ <remote-id type="sourceforge">refbase</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/refbase/refbase-0.9.5.ebuild b/app-text/refbase/refbase-0.9.5.ebuild
new file mode 100644
index 000000000000..39a921dc10c3
--- /dev/null
+++ b/app-text/refbase/refbase-0.9.5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit depend.apache depend.php webapp
+
+DESCRIPTION="Web-based solution for managing scientific literature, references and citations"
+HOMEPAGE="http://www.refbase.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="|| ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 )
+ dev-lang/php[mysql,session]
+ app-admin/webapp-config
+ app-text/bibutils"
+RDEPEND="${DEPEND}"
+
+need_apache
+need_php
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install () {
+ webapp_src_preinst
+
+ DOCS="AUTHORS BUGS ChangeLog NEWS README TODO UPDATE"
+ dodoc ${DOCS}
+ # Don't install docs to webroot
+ rm -f ${DOCS} COPYING INSTALL
+
+ cp -R * "${D}"${MY_HTDOCSDIR}
+
+ webapp_configfile ${MY_HTDOCSDIR}/initialize
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}