summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-12-28 15:47:52 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-28 15:47:52 +0100
commit47a906a1763d185c40f5e12e351b6f553573817a (patch)
treeacccb23e6ab0452f7952f0811c38bff1b7034547 /app-text/rman
parentapp-misc/vcp: Port to EAPI 7 (diff)
downloadgentoo-47a906a1763d185c40f5e12e351b6f553573817a.tar.gz
gentoo-47a906a1763d185c40f5e12e351b6f553573817a.tar.bz2
gentoo-47a906a1763d185c40f5e12e351b6f553573817a.zip
app-text/rman: Port to EAPI 7
Closes: https://bugs.gentoo.org/757570 Package-Manager: Portage-3.0.9, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-text/rman')
-rw-r--r--app-text/rman/files/rman-3.2-format-security.patch5
-rw-r--r--app-text/rman/files/rman-3.2-gentoo.patch (renamed from app-text/rman/files/rman-3.2-gentoo.diff)5
-rw-r--r--app-text/rman/files/rman-3.2-ldflags.patch6
-rw-r--r--app-text/rman/rman-3.2-r1.ebuild16
4 files changed, 11 insertions, 21 deletions
diff --git a/app-text/rman/files/rman-3.2-format-security.patch b/app-text/rman/files/rman-3.2-format-security.patch
index 77070026bdb9..4ea7740a6822 100644
--- a/app-text/rman/files/rman-3.2-format-security.patch
+++ b/app-text/rman/files/rman-3.2-format-security.patch
@@ -1,8 +1,3 @@
- rman.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/rman.c b/rman.c
-index d09e547..e5fc88d 100644
--- a/rman.c
+++ b/rman.c
@@ -1372,7 +1372,7 @@ HTML(enum command cmd) {
diff --git a/app-text/rman/files/rman-3.2-gentoo.diff b/app-text/rman/files/rman-3.2-gentoo.patch
index ece1e3807e66..676d555ce375 100644
--- a/app-text/rman/files/rman-3.2-gentoo.diff
+++ b/app-text/rman/files/rman-3.2-gentoo.patch
@@ -1,6 +1,5 @@
-diff -urN rman-3.2.orig/Makefile rman-3.2/Makefile
---- rman-3.2.orig/Makefile 2003-07-26 12:15:00.000000000 -0700
-+++ rman-3.2/Makefile 2005-07-12 01:01:37.000000000 -0700
+--- a/Makefile
++++ b/Makefile
@@ -15,13 +15,8 @@
# this must be a directory that's in your bin PATH.
# MANDIR holds the man page.
diff --git a/app-text/rman/files/rman-3.2-ldflags.patch b/app-text/rman/files/rman-3.2-ldflags.patch
index 4a6f5f5d9eab..7f0745b2e0f2 100644
--- a/app-text/rman/files/rman-3.2-ldflags.patch
+++ b/app-text/rman/files/rman-3.2-ldflags.patch
@@ -1,7 +1,5 @@
-Index: rman-3.2/Makefile
-===================================================================
---- rman-3.2.orig/Makefile
-+++ rman-3.2/Makefile
+--- a/Makefile
++++ b/Makefile
@@ -102,7 +102,7 @@ all: rman
# everyone but me zaps assertions with the -DNDEBUG flag
diff --git a/app-text/rman/rman-3.2-r1.ebuild b/app-text/rman/rman-3.2-r1.ebuild
index d57e0cb0ab0d..e27b09503ee8 100644
--- a/app-text/rman/rman-3.2-r1.ebuild
+++ b/app-text/rman/rman-3.2-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="PolyGlotMan man page translator AKA RosettaMan"
HOMEPAGE="https://sourceforge.net/projects/polyglotman/"
@@ -12,16 +12,14 @@ SRC_URI="mirror://sourceforge/polyglotman/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
RESTRICT="test"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-gentoo.diff \
- "${FILESDIR}"/${P}-ldflags.patch \
- "${FILESDIR}"/${P}-format-security.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-format-security.patch
+)
src_compile() {
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"