summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-09 12:08:56 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-09 12:08:56 +0100
commit9c398750240b1319d538dfbcebc8af0e73701d40 (patch)
treeeb1395410d5037ecc10708707bdd55b1d6f6ae3b /app-text/sword
parentdev-python/pyopencl: bump to 2020.3.1 (diff)
downloadgentoo-9c398750240b1319d538dfbcebc8af0e73701d40.tar.gz
gentoo-9c398750240b1319d538dfbcebc8af0e73701d40.tar.bz2
gentoo-9c398750240b1319d538dfbcebc8af0e73701d40.zip
app-text/sword: bump to 1.9.0 and EAPI 7
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/Manifest1
-rw-r--r--app-text/sword/sword-1.9.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/sword/Manifest b/app-text/sword/Manifest
index dc9b07298426..b34d6dd958a6 100644
--- a/app-text/sword/Manifest
+++ b/app-text/sword/Manifest
@@ -1 +1,2 @@
DIST sword-1.8.1.tar.gz 2449503 BLAKE2B 4cc130ade49211dd4def6d9410ad6a0f01b35d11df246e26bb7fd0ee5c27ef02ee06ed3ec33c7becd140fa303b4fb4b3d4ba4d62de78b86be343949d5fcf7c6d SHA512 5c08c070ea0c86b7d929bbf94c89730eb5a487986deb9edf01c08d1710356aecd1ab3bde4437a778e5fc1ceb05b63287612ec6161381c0986a36344c27d2ab36
+DIST sword-1.9.0.tar.gz 2606652 BLAKE2B cd0fd85267c81410dc6acdc45594688ac1855a6160f5d39d38e225982e1440433fbdc75f22eee52291fcbf1ef92b8ca5a40652a98d7cafbfc9186e6d132ef236 SHA512 9ed3fbb5024af1f93b1473bae0d95534d02a5b00b3c9d41a0f855cee8106dc4e330844080adbee7c3f74c0e5ce1480bf16c87c842421337a341f641bae11137f
diff --git a/app-text/sword/sword-1.9.0.ebuild b/app-text/sword/sword-1.9.0.ebuild
new file mode 100644
index 000000000000..b53e698cb50e
--- /dev/null
+++ b/app-text/sword/sword-1.9.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Library for Bible reading software"
+HOMEPAGE="https://www.crosswire.org/sword/"
+SRC_URI="https://www.crosswire.org/ftpmirror/pub/${PN}/source/v${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc-macos"
+IUSE="clucene curl debug doc icu static-libs"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ clucene? ( dev-cpp/clucene )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( AUTHORS CODINGSTYLE ChangeLog README )
+
+src_configure() {
+ use doc && DOCS+=( examples/ samples/ )
+
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}/etc"
+ -DLIB_INSTALL_DIR="${EPREFIX}/usr/$(get_libdir)"
+ -DWITH_CLUCENE=$(usex clucene)
+ -DWITH_CURL=$(usex curl)
+ -DWITH_ICU=$(usex icu)
+ -DWITH_ZLIB=1
+ )
+ # Upstream default is to build both the shared and the static library
+ use static-libs || mycmakeargs+=( -DLIBSWORD_LIBRARY_TYPE="Shared" )
+
+ cmake_src_configure
+}