summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-11-21 10:48:53 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-11-21 10:51:53 +0000
commit0e411eaaa9924a84d93ca4ff847375725c5e5096 (patch)
treebcea32ff8db96a2236586030a4ffe2030d15ba85 /app-text/tidy-html5
parentMore masks are needed for selinux vs. systemd issues (diff)
downloadgentoo-0e411eaaa9924a84d93ca4ff847375725c5e5096.tar.gz
gentoo-0e411eaaa9924a84d93ca4ff847375725c5e5096.tar.bz2
gentoo-0e411eaaa9924a84d93ca4ff847375725c5e5096.zip
app-text/tidy-html5: Initial import. Fixes bug 564884.
Package-Manager: portage-2.2.20.1 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-text/tidy-html5')
-rw-r--r--app-text/tidy-html5/Manifest1
-rw-r--r--app-text/tidy-html5/metadata.xml11
-rw-r--r--app-text/tidy-html5/tidy-html5-5.1.9.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/app-text/tidy-html5/Manifest b/app-text/tidy-html5/Manifest
new file mode 100644
index 000000000000..d0c4cfade516
--- /dev/null
+++ b/app-text/tidy-html5/Manifest
@@ -0,0 +1 @@
+DIST tidy-html5-5.1.9.zip 1077163 SHA256 1c414aea63e168c5d28ec8aad047d68e12d07f67b891f4450252d0cb68154fab SHA512 a5f18d43333f5acb6a4290bd9960fbccb1fa07b180ac3e02ee0a1ec890fd3ebef6f0f2811df05f9808220945d9810f94059f328c2d0d6827543c6697d73e0dc5 WHIRLPOOL 8b10a34ce247077c9f7450b41fbbd0135f0a88214445adddbbf70bdb296d541b75188d491961e3f9fde465c80b1e09d060160e5c0609c9ba923548ad2981aa04
diff --git a/app-text/tidy-html5/metadata.xml b/app-text/tidy-html5/metadata.xml
new file mode 100644
index 000000000000..932d6ccae5a9
--- /dev/null
+++ b/app-text/tidy-html5/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">nhatminhle/cofoja</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/tidy-html5/tidy-html5-5.1.9.ebuild b/app-text/tidy-html5/tidy-html5-5.1.9.ebuild
new file mode 100644
index 000000000000..987900573b38
--- /dev/null
+++ b/app-text/tidy-html5/tidy-html5-5.1.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Tidy the layout and correct errors in HTML, HTML5 and XML documents"
+HOMEPAGE="http://www.html-tidy.org/"
+SRC_URI="https://github.com/htacg/${PN}/archive/${PV}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-text/htmltidy"
+
+S="${WORKDIR}/${P}"
+
+DOCS=( {CODESTYLE,README,CONTRIBUTING,LICENSE,VERSION}.md )
+HTML_DOCS=( README.html )
+
+BUILD_DIR="${S}/build/cmake"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_BUILD_TYPE=Release
+ )
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cd build/cmake || die
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+}