summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/tokyodystopia/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/tokyodystopia/files')
-rw-r--r--app-text/tokyodystopia/files/fix_ldconfig.patch12
-rw-r--r--app-text/tokyodystopia/files/fix_rpath.patch61
-rw-r--r--app-text/tokyodystopia/files/remove_docinst.patch13
3 files changed, 86 insertions, 0 deletions
diff --git a/app-text/tokyodystopia/files/fix_ldconfig.patch b/app-text/tokyodystopia/files/fix_ldconfig.patch
new file mode 100644
index 000000000000..a75da590ee38
--- /dev/null
+++ b/app-text/tokyodystopia/files/fix_ldconfig.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.in b/Makefile.in
+index 60b1036..12f02b0 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -125,7 +125,6 @@ install :
+ cd man && cp -Rf $(MAN3FILES) $(DESTDIR)$(MAN3DIR)
+ mkdir -p $(DESTDIR)$(PCDIR)
+ cp -Rf $(PCFILES) $(DESTDIR)$(PCDIR)
+- [ "$$UID" == 0 ] && ldconfig || true
+ @printf '\n'
+ @printf '#================================================================\n'
+ @printf '# Thanks for using Tokyo Cabinet.\n'
diff --git a/app-text/tokyodystopia/files/fix_rpath.patch b/app-text/tokyodystopia/files/fix_rpath.patch
new file mode 100644
index 000000000000..68c0b6e03510
--- /dev/null
+++ b/app-text/tokyodystopia/files/fix_rpath.patch
@@ -0,0 +1,61 @@
+diff -ur tokyodystopia-0.9.13/Makefile.in tokyodystopia-0.9.13-new/Makefile.in
+--- tokyodystopia-0.9.13/Makefile.in 2009-07-05 04:06:06.000000000 +0200
++++ tokyodystopia-0.9.13-new/Makefile.in 2009-10-20 22:39:18.000000000 +0200
+@@ -55,8 +55,8 @@
+ LDFLAGS = @MYLDFLAGS@
+ CMDLDFLAGS = @MYCMDLDFLAGS@
+ LIBS = @LIBS@
+-LDENV = LD_RUN_PATH=/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@:.
+-RUNENV = @MYLDLIBPATHENV@=.:/lib:/usr/lib:$(LIBDIR):$(HOME)/lib:/usr/local/lib:@MYRUNPATH@
++LDENV =
++RUNENV = @MYLDLIBPATHENV@=.:$(LIBDIR)
+ POSTCMD = @MYPOSTCMD@
+
+
+diff -ur tokyodystopia-0.9.13/configure.in tokyodystopia-0.9.13-new/configure.in
+--- tokyodystopia-0.9.13/configure.in 2009-06-14 05:44:54.000000000 +0200
++++ tokyodystopia-0.9.13-new/configure.in 2009-10-20 22:40:00.000000000 +0200
+@@ -26,31 +26,14 @@
+ MYPCFILES="tokyodystopia.pc"
+
+ # Building flags
+-MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char -O2"
++MYCFLAGS="-std=c99 -Wall -fPIC -fsigned-char"
+ MYCPPFLAGS="-I. -I\$(INCLUDEDIR) -I$HOME/include -I/usr/local/include -DNDEBUG -D_GNU_SOURCE=1"
+-MYLDFLAGS="-L. -L\$(LIBDIR) -L$HOME/lib -L/usr/local/lib"
++MYLDFLAGS="-L. -L\$(LIBDIR)"
+ MYCMDLDFLAGS=""
+ MYRUNPATH="\$(LIBDIR)"
+ MYLDLIBPATHENV="LD_LIBRARY_PATH"
+ MYPOSTCMD="true"
+
+-# Building paths
+-PATH="$PATH:$HOME/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin"
+-PATH="$PATH:/opt/SUNWspro/bin:/usr/ccs/bin:/usr/xpg4/bin:/usr/xpg6/bin:/usr/ucb"
+-CPATH="$HOME/include:/usr/local/include:$CPATH"
+-LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LIBRARY_PATH"
+-LD_LIBRARY_PATH="$HOME/lib:/usr/local/lib:$LD_LIBRARY_PATH"
+-PKG_CONFIG_PATH="$HOME/lib/pkgconfig:/usr/local/lib/pkgconfig:$PKG_CONFIG_PATH"
+-export PATH CPATH LIBRARY_PATH LD_LIBRARY_PATH PKG_CONFIG_PATH
+-if type pkg-config > /dev/null 2>&1
+-then
+- PATH="$PATH:`pkg-config --variable=bindir tokyocabinet`"
+- CPATH="$CPATH:`pkg-config --variable=includedir tokyocabinet`"
+- LIBRARY_PATH="$LIBRARY_PATH:`pkg-config --variable=libdir tokyocabinet`"
+- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:`pkg-config --variable=libdir tokyocabinet`"
+-fi
+-
+-
+
+ #================================================================
+ # Options
+diff -ur tokyodystopia-0.9.13/tokyodystopia.pc.in tokyodystopia-0.9.13-new/tokyodystopia.pc.in
+--- tokyodystopia-0.9.13/tokyodystopia.pc.in 2008-02-21 10:45:01.000000000 +0100
++++ tokyodystopia-0.9.13-new/tokyodystopia.pc.in 2009-10-20 22:40:17.000000000 +0200
+@@ -10,5 +10,5 @@
+ Name: Tokyo Dystopia
+ Description: a full-text search system
+ Version: @PACKAGE_VERSION@
+-Libs: -L${libdir} -ltokyodystopia @LIBS@
++Libs: -L${libdir} -ltokyodystopia
+ Cflags: -I${includedir}
diff --git a/app-text/tokyodystopia/files/remove_docinst.patch b/app-text/tokyodystopia/files/remove_docinst.patch
new file mode 100644
index 000000000000..d513f54b753c
--- /dev/null
+++ b/app-text/tokyodystopia/files/remove_docinst.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index 8846c38..29ac11e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -117,8 +117,6 @@ install :
+ cp -Rf $(COMMANDFILES) $(DESTDIR)$(BINDIR)
+ mkdir -p $(DESTDIR)$(LIBEXECDIR)
+ cp -Rf $(CGIFILES) $(DESTDIR)$(LIBEXECDIR)
+- mkdir -p $(DESTDIR)$(DATADIR)
+- cp -Rf $(DOCUMENTFILES) $(DESTDIR)$(DATADIR)
+ mkdir -p $(DESTDIR)$(MAN1DIR)
+ cd man && cp -Rf $(MAN1FILES) $(DESTDIR)$(MAN1DIR)
+ mkdir -p $(DESTDIR)$(MAN3DIR)