summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/unac/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/unac/files')
-rw-r--r--app-text/unac/files/unac-1.8.0-automake-1.13.1.patch40
-rw-r--r--app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch47
2 files changed, 87 insertions, 0 deletions
diff --git a/app-text/unac/files/unac-1.8.0-automake-1.13.1.patch b/app-text/unac/files/unac-1.8.0-automake-1.13.1.patch
new file mode 100644
index 000000000000..eaad52a53f14
--- /dev/null
+++ b/app-text/unac/files/unac-1.8.0-automake-1.13.1.patch
@@ -0,0 +1,40 @@
+From 43e4c8788491c378862654933cc6d59d46f571c6 Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 22 Jul 2013 23:07:04 -0400
+Subject: [PATCH] build: modernize for automake-1.14
+
+https://bugs.gentoo.org/show_bug.cgi?id=467618
+---
+ Makefile.am | 2 +-
+ configure.ac | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index b4c658c..b40192e 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -20,7 +20,7 @@
+ # Documentation
+ #
+ man_MANS = unaccent.1 unac.3
+-INCLUDES = -DUNAC_VERSION=\"$(VERSION)\"
++AM_CPPFLAGS = -DUNAC_VERSION=\"$(VERSION)\"
+
+ #
+ # Support programs
+diff --git a/configure.ac b/configure.ac
+index 4a4eab6..444a9d5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,7 +26,7 @@ AC_SUBST(MICRO_VERSION)
+ AM_INIT_AUTOMAKE([unac], $VERSION, nosubst)
+ AC_PREREQ(2.50)
+
+-AM_CONFIG_HEADER(config.h)
++AC_CONFIG_HEADERS([config.h])
+
+ AC_PROG_MAKE_SET
+
+--
+1.8.3.2
+
diff --git a/app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch b/app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch
new file mode 100644
index 000000000000..ca1d50274da6
--- /dev/null
+++ b/app-text/unac/files/unac-1.8.0-debian-gcc-4.4-bug-556379.patch
@@ -0,0 +1,47 @@
+See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=556379
+
+diff -r fd7eb0d70970 unac-1.8.0/unac.c
+--- a/unac-1.8.0/unac.c Fri Sep 17 10:35:14 2010 +0200
++++ b/unac-1.8.0/unac.c Fri Sep 17 10:36:07 2010 +0200
+@@ -13873,9 +13873,9 @@
+ *out_lengthp = 0;
+ } else {
+ char* utf16 = 0;
+- int utf16_length = 0;
++ size_t utf16_length = 0;
+ char* utf16_unaccented = 0;
+- int utf16_unaccented_length = 0;
++ size_t utf16_unaccented_length = 0;
+
+ if(convert(charset, utf16be(), in, in_length, &utf16, &utf16_length) < 0) {
+ return -1;
+diff -r fd7eb0d70970 unac-1.8.0/unaccent.c
+--- a/unac-1.8.0/unaccent.c Fri Sep 17 10:35:14 2010 +0200
++++ b/unac-1.8.0/unaccent.c Fri Sep 17 10:40:34 2010 +0200
+@@ -90,7 +90,7 @@
+ const char* charset = argv[optind++];
+
+ char* unaccented = 0;
+- int unaccented_length = 0;
++ size_t unaccented_length = 0;
+
+ if(optind >= argc) {
+ #define BUFFER_SIZE 10240
+@@ -101,7 +101,7 @@
+ perror("");
+ exit(1);
+ }
+- printf("%.*s", unaccented_length, unaccented);
++ printf("%.*s", (int)unaccented_length, unaccented);
+ }
+ } else {
+ const char* string = argv[optind++];
+@@ -114,7 +114,7 @@
+
+ if(debug_level > UNAC_DEBUG_NONE)
+ fprintf(stderr, "unaccented version is ");
+- printf("%.*s\n", unaccented_length, unaccented);
++ printf("%.*s\n", (int)unaccented_length, unaccented);
+
+ if(optind < argc) {
+ const char* expected = argv[optind++];