summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/unpaper
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/unpaper')
-rw-r--r--app-text/unpaper/Manifest2
-rw-r--r--app-text/unpaper/metadata.xml11
-rw-r--r--app-text/unpaper/unpaper-5.1.ebuild38
-rw-r--r--app-text/unpaper/unpaper-6.1-r1.ebuild42
-rw-r--r--app-text/unpaper/unpaper-6.1.ebuild40
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild42
6 files changed, 175 insertions, 0 deletions
diff --git a/app-text/unpaper/Manifest b/app-text/unpaper/Manifest
new file mode 100644
index 000000000000..ecf2b48ad870
--- /dev/null
+++ b/app-text/unpaper/Manifest
@@ -0,0 +1,2 @@
+DIST unpaper-5.1.tar.xz 2861432 SHA256 5380417efb5a766d132b496000ad9772a5338b87e37abfa3f10255e9f59ee7c1 SHA512 5ccd90c4c92774085df6cee5552d72d538d3ee553f95ca3d2bea850975ac6e728be97aa7dca194ba44ef8156c26c19d61d051c4581100f8c553998d9a86cefdf WHIRLPOOL 75006b03908c6086236744cdff51d1dc66b80a94e9f7e3630444af149ce235c7b0c54af2954e7f093ecc23f6e86d1478333d991db8ae223e212ebc0a92c6dfee
+DIST unpaper-6.1.tar.xz 2655724 SHA256 237c84f5da544b3f7709827f9f12c37c346cdf029b1128fb4633f9bafa5cb930 SHA512 afef705985d3c265672c9e42130acc34befc080c361f3169e299b5110c662d0b9845a9d0ca4fc3aad468f49967ded36fb60ffed296373569dd7337c3cb81e79c WHIRLPOOL e88a296f1b0718a593d70b769e4ed122b4ca92fb802d3a8e74da49dbf756cac2782cbe754ed7a6c0cf73adf73b7aa970ef6154ee2c8ce5f42da127ccee2d8936
diff --git a/app-text/unpaper/metadata.xml b/app-text/unpaper/metadata.xml
new file mode 100644
index 000000000000..ed58eb5dac66
--- /dev/null
+++ b/app-text/unpaper/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Flameeyes/unpaper</remote-id>
+ <bugs-to>https://github.com/Flameeyes/unpaper/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/unpaper/unpaper-5.1.ebuild b/app-text/unpaper/unpaper-5.1.ebuild
new file mode 100644
index 000000000000..649b50e06f48
--- /dev/null
+++ b/app-text/unpaper/unpaper-5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-2 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( media-libs/netpbm[png] )
+ dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets"
+RDEPEND=""
+
+if [[ ${PV} == 9999 ]]; then
+ src_prepare() {
+ eautoreconf
+ }
+fi
+
+src_configure() {
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
diff --git a/app-text/unpaper/unpaper-6.1-r1.ebuild b/app-text/unpaper/unpaper-6.1-r1.ebuild
new file mode 100644
index 000000000000..c973f26c2bcc
--- /dev/null
+++ b/app-text/unpaper/unpaper-6.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-2 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="libav test"
+
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]]; then
+ src_prepare() {
+ eautoreconf
+ autotools-utils_src_prepare
+ }
+fi
diff --git a/app-text/unpaper/unpaper-6.1.ebuild b/app-text/unpaper/unpaper-6.1.ebuild
new file mode 100644
index 000000000000..8e0ecf3d699c
--- /dev/null
+++ b/app-text/unpaper/unpaper-6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-2 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="test"
+
+RDEPEND="|| ( >=media-video/libav-10[encode] >=media-video/ffmpeg-2[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]]; then
+ src_prepare() {
+ eautoreconf
+ autotools-utils_src_prepare
+ }
+fi
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
new file mode 100644
index 000000000000..c973f26c2bcc
--- /dev/null
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-2 autotools
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+IUSE="libav test"
+
+RDEPEND="
+ libav? ( >=media-video/libav-10:0=[encode] )
+ !libav? ( >=media-video/ffmpeg-2:0=[encode] )"
+DEPEND="dev-libs/libxslt
+ app-text/docbook-xsl-ns-stylesheets
+ virtual/pkgconfig
+ ${RDEPEND}"
+
+# gcc can generate slightly different code that leads to slightly different
+# images. Wait until we get a better testsuite.
+RESTRICT="test"
+
+if [[ ${PV} == 9999 ]]; then
+ src_prepare() {
+ eautoreconf
+ autotools-utils_src_prepare
+ }
+fi