summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xfbib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xfbib')
-rw-r--r--app-text/xfbib/Manifest1
-rw-r--r--app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch106
-rw-r--r--app-text/xfbib/files/xfbib-0.0.2-validate.patch19
-rw-r--r--app-text/xfbib/metadata.xml8
-rw-r--r--app-text/xfbib/xfbib-0.0.2-r1.ebuild41
5 files changed, 175 insertions, 0 deletions
diff --git a/app-text/xfbib/Manifest b/app-text/xfbib/Manifest
new file mode 100644
index 000000000000..3d97305934b7
--- /dev/null
+++ b/app-text/xfbib/Manifest
@@ -0,0 +1 @@
+DIST xfbib-0.0.2.tar.bz2 340703 SHA256 eeb668b5cedbc9a9b4d8e54767fb7262f173dd9e440031b94580ca108b95f920 SHA512 7f6f812bfdb6b95574f66b63e51fb1a70ce20fd795b6070b055cdc8e753656a266237be92a7e60865d9f1e5fa750be0af3404ecf219a8a5d89dde505c759aebc WHIRLPOOL b45d18574479c42b3fe473d38b217fa603ff0d69a8f678ea328e7af72d8bb92121dfc450e33f46b747e3a8c25e02aa689d16ba61c988bdb28815ffac52bc0807
diff --git a/app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch b/app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch
new file mode 100644
index 000000000000..0759dbf4e61d
--- /dev/null
+++ b/app-text/xfbib/files/xfbib-0.0.2-libxfce4ui.patch
@@ -0,0 +1,106 @@
+http://bugzilla.xfce.org/show_bug.cgi?id=9568
+
+--- src/entry_edit_dialog.c
++++ src/entry_edit_dialog.c
+@@ -17,7 +17,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <config.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+
+ #include "entry_edit_dialog.h"
+ #include "entry.h"
+@@ -589,11 +589,13 @@
+ key = (char *) gtk_entry_get_text(GTK_ENTRY(key_entry));
+ if ((type = gtk_combo_box_get_active_text(GTK_COMBO_BOX(combobox))) == NULL) {
+ _DEBUG(("No type selected"));
+- xfce_warn(_("No type was selected"));
++ /* xfce_warn(_("No type was selected")); */
++ xfce_dialog_show_warning(NULL,NULL,_("No type was selected"));
+ continue;
+ } else if (strcmp(key, "") == 0) {
+ _DEBUG(("No key selected"));
+- xfce_warn(_("No key was selected"));
++ /* xfce_warn(_("No key was selected")); */
++ xfce_dialog_show_warning(NULL,NULL,_("No key was selected"));
+ continue;
+ } else {
+ if (selected == NULL) {
+--- src/menubar.c
++++ src/menubar.c
+@@ -15,7 +15,7 @@
+ */
+
+ #include <gtk/gtk.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+ #include <config.h>
+
+--- src/open.c
++++ src/open.c
+@@ -14,7 +14,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <config.h>
+ #include <string.h>
+ #include <stdlib.h>
+--- src/open_dialog.c
++++ src/open_dialog.c
+@@ -14,7 +14,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+ #include <string.h>
+ #include <stdlib.h>
+--- src/save_dialog.c
++++ src/save_dialog.c
+@@ -15,7 +15,7 @@
+ */
+
+ #include <libintl.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <config.h>
+
+ #include "xfbib.h"
+--- src/string_edit_dialog.c
++++ src/string_edit_dialog.c
+@@ -15,7 +15,7 @@
+ */
+
+ #include <gtk/gtk.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+
+ #include "debug.h"
+ #include "strings.h"
+--- src/treeview.c
++++ src/treeview.c
+@@ -14,7 +14,7 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
+ */
+
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+ #include <config.h>
+ #include <string.h>
+--- src/xfbib.c
++++ src/xfbib.c
+@@ -20,7 +20,7 @@
+
+ #include <gtk/gtk.h>
+ #include <stdlib.h>
+-#include <libxfcegui4/libxfcegui4.h>
++#include <libxfce4ui/libxfce4ui.h>
+ #include <libintl.h>
+
+ #include "window.h"
diff --git a/app-text/xfbib/files/xfbib-0.0.2-validate.patch b/app-text/xfbib/files/xfbib-0.0.2-validate.patch
new file mode 100644
index 000000000000..a072b730c3a6
--- /dev/null
+++ b/app-text/xfbib/files/xfbib-0.0.2-validate.patch
@@ -0,0 +1,19 @@
+--- xfbib.desktop
++++ xfbib.desktop
+@@ -1,13 +1,11 @@
+-
+ [Desktop Entry]
+-Encoding=UTF-8
+ Name=Xfbib
+ Exec=xfbib
+ Icon=xfbib
+ Type=Application
+ Comment=A BibTeX editor for Xfce
+-Terminal=0
+-MimeType=text/x-bibtex
+-Categories=Application;Office;GTK;
++Terminal=false
++MimeType=text/x-bibtex;
++Categories=Office;GTK;
+ GenericName=
+ StartupNotify=false
diff --git a/app-text/xfbib/metadata.xml b/app-text/xfbib/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/app-text/xfbib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-text/xfbib/xfbib-0.0.2-r1.ebuild b/app-text/xfbib/xfbib-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..3641d5beb6d0
--- /dev/null
+++ b/app-text/xfbib/xfbib-0.0.2-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="a lightweight BibTeX editor"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfbib"
+SRC_URI="http://goodies.xfce.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.12
+ >=x11-libs/gtk+-2.10:2
+ >=xfce-base/libxfce4ui-4.8
+ >=xfce-base/libxfce4util-4.8"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/${P}-validate.patch
+ "${FILESDIR}"/${P}-libxfce4ui.patch
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ # This is to prevent eautoreconfigure:
+ sed -i -e 's:libxfcegui4-1.0:libxfce4ui-1:' configure || die
+ sed -i -e 's:$(LIBXFCE4UTIL_CFLAGS):& $(LIBXFCEGUI4_CFLAGS):' src/Makefile.in || die
+
+ xfconf_src_prepare
+}