summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-text/xml2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-text/xml2')
-rw-r--r--app-text/xml2/Manifest1
-rw-r--r--app-text/xml2/files/xml2-0.4-libxml2.patch53
-rw-r--r--app-text/xml2/metadata.xml5
-rw-r--r--app-text/xml2/xml2-0.5.ebuild18
4 files changed, 77 insertions, 0 deletions
diff --git a/app-text/xml2/Manifest b/app-text/xml2/Manifest
new file mode 100644
index 000000000000..7cebcb4bc5d2
--- /dev/null
+++ b/app-text/xml2/Manifest
@@ -0,0 +1 @@
+DIST xml2-0.5.tar.gz 86318 SHA256 e3203a5d3e5d4c634374e229acdbbe03fea41e8ccdef6a594a3ea50a50d29705 SHA512 76b6523e1b64af32529fd8cec52f61f3ca45e452c1398772367f8389368bb7712698e4ba6cb6c8e50e92f68f7f9517f90668c73016e11797931ddb6858782aba WHIRLPOOL 3f2cad5046f94e327b396c8c334691b53335b791c0d912ef4e9bc515543507b0085e660bac2ad716bfd4923b3aab5c9e01f42a4bca92b28c037ee0f490b561d3
diff --git a/app-text/xml2/files/xml2-0.4-libxml2.patch b/app-text/xml2/files/xml2-0.4-libxml2.patch
new file mode 100644
index 000000000000..065049188c5f
--- /dev/null
+++ b/app-text/xml2/files/xml2-0.4-libxml2.patch
@@ -0,0 +1,53 @@
+diff -ur xml2-0.4.orig/2xml.c xml2-0.4/2xml.c
+--- xml2-0.4.orig/2xml.c 2003-12-24 22:28:48.000000000 +0200
++++ xml2-0.4/2xml.c 2008-05-14 20:02:40.000000000 +0300
+@@ -24,7 +24,7 @@
+ #include <assert.h>
+ #include <ctype.h>
+
+-#include <HTMLparser.h>
++#include <libxml/HTMLparser.h>
+
+ int do_html;
+ int in_tag = 0;
+diff -ur xml2-0.4.orig/configure.ac xml2-0.4/configure.ac
+--- xml2-0.4.orig/configure.ac 2008-02-07 18:11:54.000000000 +0200
++++ xml2-0.4/configure.ac 2008-05-14 20:05:12.000000000 +0300
+@@ -11,7 +11,7 @@
+ AC_PROG_CC
+
+ # Checks for libraries.
+-PKG_CHECK_MODULES(XML, libxml)
++PKG_CHECK_MODULES(XML, libxml-2.0)
+ AC_SUBST(XML_LIBS)
+ AC_SUBST(XML_CFLAGS)
+
+diff -ur xml2-0.4.orig/Makefile.am xml2-0.4/Makefile.am
+--- xml2-0.4.orig/Makefile.am 2008-02-07 17:58:13.000000000 +0200
++++ xml2-0.4/Makefile.am 2008-05-14 20:06:10.000000000 +0300
+@@ -1,9 +1,9 @@
+ AM_CPPFLAGS = $(XML_CFLAGS)
+ bin_PROGRAMS = xml2 2xml csv2 2csv
+ xml2_SOURCES = xml2.c
+-xml2_LDADD = -lxml
++xml2_LDADD = -lxml2
+ 2xml_SOURCES = 2xml.c
+-2xml_LDADD = -lxml
++2xml_LDADD = -lxml2
+ csv2_SOURCES = csv2.c
+ 2csv_SOURCES = 2csv.c
+
+diff -ur xml2-0.4.orig/xml2.c xml2-0.4/xml2.c
+--- xml2-0.4.orig/xml2.c 2001-10-28 06:29:46.000000000 +0200
++++ xml2-0.4/xml2.c 2008-05-14 20:03:31.000000000 +0300
+@@ -24,8 +24,8 @@
+ #include <string.h>
+ #include <ctype.h>
+
+-#include <parser.h>
+-#include <HTMLparser.h>
++#include <libxml/parser.h>
++#include <libxml/HTMLparser.h>
+
+ struct node
+ {
diff --git a/app-text/xml2/metadata.xml b/app-text/xml2/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/app-text/xml2/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>
diff --git a/app-text/xml2/xml2-0.5.ebuild b/app-text/xml2/xml2-0.5.ebuild
new file mode 100644
index 000000000000..58b99b6a651b
--- /dev/null
+++ b/app-text/xml2/xml2-0.5.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="These tools are used to convert XML and HTML to and from a line-oriented format"
+HOMEPAGE="http://dan.egnor.name/xml2"
+SRC_URI="http://download.ofb.net/gale/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"