summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Cerisara <andreacerisara@gmail.com>2020-03-30 21:07:54 +1100
committerJoonas Niilola <juippis@gentoo.org>2020-04-05 10:17:56 +0300
commit6f9df9cfbe5099596ce415f6118a59e0c752021d (patch)
treec6c0b226a9dc542179492be33b6a39abac868a88 /app-text/xmldiff
parentdev-libs/bglibs: properly align buffers on stack (diff)
downloadgentoo-6f9df9cfbe5099596ce415f6118a59e0c752021d.tar.gz
gentoo-6f9df9cfbe5099596ce415f6118a59e0c752021d.tar.bz2
gentoo-6f9df9cfbe5099596ce415f6118a59e0c752021d.zip
app-text/xmldiff: version bump to 2.3
- update docs - update license - remove dev-python/future dependency Closes: https://bugs.gentoo.org/701592 Signed-off-by: Andrea Cerisara <andreacerisara@gmail.com> Package-Manager: Portage-2.3.89, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/15171 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text/xmldiff')
-rw-r--r--app-text/xmldiff/Manifest1
-rw-r--r--app-text/xmldiff/metadata.xml15
-rw-r--r--app-text/xmldiff/xmldiff-2.3.ebuild26
3 files changed, 38 insertions, 4 deletions
diff --git a/app-text/xmldiff/Manifest b/app-text/xmldiff/Manifest
index 721c919fd50f..ebe2395673b2 100644
--- a/app-text/xmldiff/Manifest
+++ b/app-text/xmldiff/Manifest
@@ -1 +1,2 @@
DIST xmldiff-1.1.1.tar.gz 36429 BLAKE2B 2d84a1552851b0964ac837a30c61a99a3360292020251aa06ed71723e89b6a8f89a79107c69a317b16d810ee74241d38837d382b0dcb134b43f72f58ee2b6ea2 SHA512 cf65bdd827b76781b693089b8742f6358931456c4fdfd0f4b2a9e13b30101b48379ea9c2bf3dcb32d6d22198769262f2603172ffa877bec2ddfa5fabfdf74326
+DIST xmldiff-2.3.tar.gz 92561 BLAKE2B f18805a9aa00a99a3f63640de60d3ea37393208ade00a14b817d42706bb1b3e407f2645d7df5b5e9f4d60d75d48afe6475e5c1f1bab24ea6fdd78d8646c79b58 SHA512 1dc3f76f51df3c506af827c9a7f67386143b4ce49c2159302e07c5f56054ffd9e858f086bb76d64a038b7e9ae7c116d1146714d4528ea9d53e23e1bacb4bb812
diff --git a/app-text/xmldiff/metadata.xml b/app-text/xmldiff/metadata.xml
index 14c1b6f3de84..70f8606c9a10 100644
--- a/app-text/xmldiff/metadata.xml
+++ b/app-text/xmldiff/metadata.xml
@@ -1,13 +1,20 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>andreacerisara@gmail.com</email>
+ <name>Andrea Cerisara</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<longdescription>
A python tool that figures out the differences between two
similar XML files, in the same way the diff utility does.
- Xmldiff was initially developed for the Narval project and could also be
- used as a library or as a command line tool. It can work either with XML
- files or DOM trees.
+ Xmldiff was initially developed for the Narval project and can
+ be used as a library or as a command line tool. It can work either
+ with XML files or DOM trees.
</longdescription>
<upstream>
<remote-id type="github">Shoobx/xmldiff</remote-id>
diff --git a/app-text/xmldiff/xmldiff-2.3.ebuild b/app-text/xmldiff/xmldiff-2.3.ebuild
new file mode 100644
index 000000000000..715355478563
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+DISTUTILS_USE_SETUPTOOLS="rdepend"
+inherit distutils-r1
+
+distutils_enable_tests unittest
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="https://github.com/Shoobx/xmldiff"
+SRC_URI="https://github.com/Shoobx/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/setuptools
+ dev-python/lxml
+ dev-python/six"
+
+DOCS=( CHANGES.rst README.rst )