summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-01-28 16:59:25 +0100
committerMichael Weber <xmw@gentoo.org>2018-01-28 17:18:59 +0100
commit711ff8dc7fdd747df370ec9d1d3a9d1a323ac37d (patch)
tree12a23738958127fef887170cc4d8578e77306071 /app-text/zathura-djvu
parentapp-text/zathura-cb: Version bump. (diff)
downloadgentoo-711ff8dc7fdd747df370ec9d1d3a9d1a323ac37d.tar.gz
gentoo-711ff8dc7fdd747df370ec9d1d3a9d1a323ac37d.tar.bz2
gentoo-711ff8dc7fdd747df370ec9d1d3a9d1a323ac37d.zip
app-text/zathura-djvu: Version bump.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-text/zathura-djvu')
-rw-r--r--app-text/zathura-djvu/Manifest1
-rw-r--r--app-text/zathura-djvu/zathura-djvu-0.2.7.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/zathura-djvu/Manifest b/app-text/zathura-djvu/Manifest
index cd9057009557..dfda93333193 100644
--- a/app-text/zathura-djvu/Manifest
+++ b/app-text/zathura-djvu/Manifest
@@ -1 +1,2 @@
DIST zathura-djvu-0.2.6.tar.gz 11137 BLAKE2B 23efc23cd53068abb3e118d6dc9b1e875c3f292d2e7ab49abbf6c599d6241c37959e9f74ac2b0f06838cadca0a07e39e1dda2e188f6861b72d4cd7a4bb1fcc62 SHA512 8534faa0de896ffea8d8d6f2d0c22697f2fd6ae3f73e955f5077e0a0656c13fd8823580f1b89c4b5aebb5189c69642ef690fc9167be178ce9533e9bb5d483dac
+DIST zathura-djvu-0.2.7.tar.gz 10909 BLAKE2B 6a55927aa99ec5d29b8f24922c4871c050c25f6c166ee3435390488deefd13f1f81f4286a0c3cd348e4f550e1b4082b9a7c5c7cce40371f8fb62074c87a2d372 SHA512 f0a33f53caced4cb90354e431d180a3b357db300ba5a376051e45f5409e8476105640e92768c2a31bdbbb0b37dea05df24a6489799c556e30336013f807b28b6
diff --git a/app-text/zathura-djvu/zathura-djvu-0.2.7.ebuild b/app-text/zathura-djvu/zathura-djvu-0.2.7.ebuild
new file mode 100644
index 000000000000..06d973da811e
--- /dev/null
+++ b/app-text/zathura-djvu/zathura-djvu-0.2.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="DjVu plug-in for zathura"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-text/djvu-3.5.24-r1:=
+ >=app-text/zathura-0.3.8
+ dev-libs/glib:2=
+ x11-libs/cairo:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}