summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2018-11-11 02:54:43 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-11-11 02:55:34 +0300
commitc620bdc2b3a0872b6bc6ef0a9c624a411328db0d (patch)
tree75c42aa0e2462e67ecd259e2ec1a974da3e9e0ed /app-text/zathura
parentsys-apps/opentmpfiles: sync live ebuild (diff)
downloadgentoo-c620bdc2b3a0872b6bc6ef0a9c624a411328db0d.tar.gz
gentoo-c620bdc2b3a0872b6bc6ef0a9c624a411328db0d.tar.bz2
gentoo-c620bdc2b3a0872b6bc6ef0a9c624a411328db0d.zip
app-text/zathura: find libm properly
Closes: https://bugs.gentoo.org/669850 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-text/zathura')
-rw-r--r--app-text/zathura/files/zathura-find-libm.patch26
-rw-r--r--app-text/zathura/zathura-0.4.1.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/app-text/zathura/files/zathura-find-libm.patch b/app-text/zathura/files/zathura-find-libm.patch
new file mode 100644
index 000000000000..4995238fb8da
--- /dev/null
+++ b/app-text/zathura/files/zathura-find-libm.patch
@@ -0,0 +1,26 @@
+From cc99b8d3491ce0cd30ba56decc33d811478bab0c Mon Sep 17 00:00:00 2001
+From: Sebastian Ramacher <sebastian@ramacher.at>
+Date: Tue, 30 Oct 2018 00:39:19 +0100
+Subject: [PATCH] Search for m instead of libm (fixes #757)
+
+Thanks to Franz Trischberger for the fix.
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index f54f104..afe9ae8 100644
+--- a/meson.build
++++ b/meson.build
+@@ -36,7 +36,7 @@ dbusinterfacesdir = join_paths(datadir, 'dbus-1', 'interfaces')
+ plugindir = join_paths(get_option('libdir'), 'zathura')
+
+ # required dependencies
+-libm = cc.find_library('libm', required: false)
++libm = cc.find_library('m', required: false)
+ girara = dependency('girara-gtk3', version: '>=0.2.9')
+ glib = dependency('glib-2.0', version: '>=2.50')
+ gio = dependency('gio-unix-2.0', required: host_machine.system() != 'windows')
+--
+2.18.0
+
diff --git a/app-text/zathura/zathura-0.4.1.ebuild b/app-text/zathura/zathura-0.4.1.ebuild
index 1b9071f73e74..446cef59dfaf 100644
--- a/app-text/zathura/zathura-0.4.1.ebuild
+++ b/app-text/zathura/zathura-0.4.1.ebuild
@@ -21,6 +21,8 @@ LICENSE="ZLIB"
SLOT="0"
IUSE="+magic seccomp sqlite synctex test"
+PATCHES=( "${FILESDIR}"/${PN}-find-libm.patch )
+
RDEPEND="dev-libs/appstream
>=dev-libs/girara-0.3.1
>=dev-libs/glib-2.50:2