summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2021-10-05 22:26:38 +0900
committerAkinori Hattori <hattya@gentoo.org>2021-10-05 22:26:38 +0900
commit0964f4706de78ade27d95aa3cb82bb5d0b58f710 (patch)
treef8265735e9be480efcd39677def7a3593c7acdf9 /app-text
parentapp-admin/ansible-lint: remove setuptools from RDEPEND (diff)
downloadgentoo-0964f4706de78ade27d95aa3cb82bb5d0b58f710.tar.gz
gentoo-0964f4706de78ade27d95aa3cb82bb5d0b58f710.tar.bz2
gentoo-0964f4706de78ade27d95aa3cb82bb5d0b58f710.zip
app-text/namazu: update to EAPI 7
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/namazu/namazu-2.0.21.ebuild14
-rw-r--r--app-text/namazu/namazu-2.0.22_pre7.ebuild14
2 files changed, 14 insertions, 14 deletions
diff --git a/app-text/namazu/namazu-2.0.21.ebuild b/app-text/namazu/namazu-2.0.21.ebuild
index 5d0b4d0d14e3..68d7835962bd 100644
--- a/app-text/namazu/namazu-2.0.21.ebuild
+++ b/app-text/namazu/namazu-2.0.21.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit autotools elisp-common
@@ -30,8 +30,8 @@ RDEPEND="dev-perl/File-MMagic
dev-lang/tk:0
www-client/lynx
)"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
PATCHES=(
"${FILESDIR}"/${PN}-gentoo.patch
@@ -43,8 +43,8 @@ PATCHES=(
src_prepare() {
default
- mv configure.{in,ac}
- mv tk${PN}/configure.{in,ac}
+ mv configure.{in,ac} || die
+ mv tk${PN}/configure.{in,ac} || die
eautoreconf
}
@@ -64,7 +64,7 @@ src_configure() {
}
src_compile() {
- emake
+ default
if use emacs; then
cd lisp
diff --git a/app-text/namazu/namazu-2.0.22_pre7.ebuild b/app-text/namazu/namazu-2.0.22_pre7.ebuild
index 8517c8554367..e6044e412bdf 100644
--- a/app-text/namazu/namazu-2.0.22_pre7.ebuild
+++ b/app-text/namazu/namazu-2.0.22_pre7.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI="7"
inherit autotools elisp-common
@@ -32,8 +32,8 @@ RDEPEND="dev-perl/File-MMagic
dev-lang/tk:0
www-client/lynx
)"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
S="${WORKDIR}"/${MY_P}
PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
@@ -41,8 +41,8 @@ PATCHES=( "${FILESDIR}"/${PN}-gentoo.patch )
src_prepare() {
default
- mv configure.{in,ac}
- mv tk${PN}/configure.{in,ac}
+ mv configure.{in,ac} || die
+ mv tk${PN}/configure.{in,ac} || die
eautoreconf
}
@@ -62,7 +62,7 @@ src_configure() {
}
src_compile() {
- emake
+ default
if use emacs; then
cd lisp