summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2021-08-04 23:29:09 +0200
committerPacho Ramos <pacho@gentoo.org>2021-08-04 23:29:19 +0200
commit0a2cfc11a4d27346c358676a6a806a0cfb860004 (patch)
tree5922ba709e38950b0f999b4c7574843780c2b23e /app-text
parentprofiles: last-rite app-backup/zbackup (diff)
downloadgentoo-0a2cfc11a4d27346c358676a6a806a0cfb860004.tar.gz
gentoo-0a2cfc11a4d27346c358676a6a806a0cfb860004.tar.bz2
gentoo-0a2cfc11a4d27346c358676a6a806a0cfb860004.zip
app-text/evince: Handle schemas installation
Also simplify ebuild and rely on exported phases from inherited eclasses Closes: https://bugs.gentoo.org/802819 Thanks-to: Alex Xu Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/evince/evince-40.4.ebuild18
1 files changed, 8 insertions, 10 deletions
diff --git a/app-text/evince/evince-40.4.ebuild b/app-text/evince/evince-40.4.ebuild
index f3d4f7e417e1..c63d4e42db3f 100644
--- a/app-text/evince/evince-40.4.ebuild
+++ b/app-text/evince/evince-40.4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit gnome.org meson systemd xdg
+inherit gnome.org gnome2-utils meson systemd xdg
DESCRIPTION="Simple document viewer for GNOME"
HOMEPAGE="https://wiki.gnome.org/Apps/Evince"
@@ -70,7 +70,7 @@ PATCHES=(
)
src_prepare() {
- default
+ xdg_src_prepare
# Do not depend on adwaita-icon-theme, bug #326855, #391859
# https://gitlab.freedesktop.org/xdg/default-icon-theme/issues/7
@@ -114,14 +114,12 @@ src_configure() {
meson_src_configure
}
-src_compile() {
- meson_src_compile
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
}
-src_test() {
- meson_src_test
-}
-
-src_install() {
- meson_src_install
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
}