summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Joliet <marcec@gmx.de>2017-10-30 20:04:54 +0100
committerMichael Palimaka <kensington@gentoo.org>2017-11-04 18:42:17 +1100
commit0bc75d9ec36b6dc755b84b8271513fad91232c41 (patch)
tree87ac90dd289f80b552c94392de7c3b8edc7bfe4a /app-text
parentnet-vpn/libreswan: add 3.22 (diff)
downloadgentoo-0bc75d9ec36b6dc755b84b8271513fad91232c41.tar.gz
gentoo-0bc75d9ec36b6dc755b84b8271513fad91232c41.tar.bz2
gentoo-0bc75d9ec36b6dc755b84b8271513fad91232c41.zip
app-text/asciidoc-8.6.10: version bump
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-text')
-rw-r--r--app-text/asciidoc/Manifest1
-rw-r--r--app-text/asciidoc/asciidoc-8.6.10.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-text/asciidoc/Manifest b/app-text/asciidoc/Manifest
index a113958d84ca..151a4338ba1b 100644
--- a/app-text/asciidoc/Manifest
+++ b/app-text/asciidoc/Manifest
@@ -1 +1,2 @@
+DIST asciidoc-8.6.10.tar.gz 577208 SHA256 9e52f8578d891beaef25730a92a6e723596ddbd07bfe0d2a56486fcf63a0b983 SHA512 6ecc86977baaf1c756691e3f661e43ef2bb24e606898f6075bfa6f174d1fdc5e77d00853ffe014847e295364349d6ad34f3b8209cb97870e0233012fc38a281a WHIRLPOOL 36c097befed3befb901ceb0c42079488462c31acb92719f22da88a76804a692463c4ee37872c4b5e8c15711ed26734659cb52e61cd483b2062f0109a16c6af47
DIST asciidoc-8.6.9.tar.gz 907253 SHA256 78db9d0567c8ab6570a6eff7ffdf84eadd91f2dfc0a92a2d0105d323cab4e1f0 SHA512 1984482010dbd35c3a1def67f4915ce83ecfc29a7463f84aa312107d7a9ff647978f57615462c65e885bea424eed89a212df728cc3acd3c63df1c763dfa5e955 WHIRLPOOL dbd576ed3b7bcaf46afd33d9aae7a94f82fb171fa73f0b99f737b6934f62927ea11e1290aeac141ce5de27f66a56d7ed2d110f2b0d84e0598e858eac0e52b35d
diff --git a/app-text/asciidoc/asciidoc-8.6.10.ebuild b/app-text/asciidoc/asciidoc-8.6.10.ebuild
new file mode 100644
index 000000000000..7bd3987cf6e3
--- /dev/null
+++ b/app-text/asciidoc/asciidoc-8.6.10.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit autotools python-single-r1 readme.gentoo-r1
+
+DESCRIPTION="AsciiDoc is a plain text human readable/writable document format"
+HOMEPAGE="http://asciidoc.org/"
+SRC_URI="https://github.com/asciidoc/asciidoc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="examples graphviz highlight test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75
+ dev-libs/libxslt
+ ${PYTHON_DEPS}
+ graphviz? ( media-gfx/graphviz )
+ highlight? (
+ || (
+ dev-util/source-highlight
+ dev-python/pygments[${PYTHON_USEDEP}]
+ app-text/highlight
+ )
+ )"
+DEPEND="
+ test? (
+ app-text/dvipng
+ dev-texlive/texlive-latex
+ dev-util/source-highlight
+ media-gfx/graphviz
+ media-gfx/imagemagick
+ media-sound/lilypond
+ ${PYTHON_DEPS}
+ )"
+
+DOC_CONTENTS="
+If you are going to use a2x, please also look at a2x(1) under
+REQUISITES for a list of runtime dependencies.
+"
+
+src_prepare() {
+ default
+ # Only needed for prefix - harmless (does nothing) otherwise
+ sed -i -e "s:^CONF_DIR=.*:CONF_DIR='${EPREFIX}/etc/asciidoc':" \
+ "${S}/asciidoc.py" || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --sysconfdir="${EPREFIX}"/usr/share
+}
+
+src_test() {
+ local -x ASCIIDOC_PY=asciidoc.py
+ "${EPYTHON}" tests/test${PN}.py update || die
+ "${EPYTHON}" tests/test${PN}.py run || die
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED%/}"/usr/bin/*.py
+
+ readme.gentoo_create_doc
+ dodoc BUGS.txt CHANGELOG.txt README.asciidoc docbook-xsl/asciidoc-docbook-xsl.txt \
+ dblatex/dblatex-readme.txt filters/code/code-filter-readme.txt
+
+ # Below results in some files being installed twice in different locations, but they are
+ # in the right place, uncompressed, and there won't be any broken links. See bug #483336
+ if use examples; then
+ # examples/website is full of relative symlinks,
+ # deref them for copying, which dodoc doesn't do
+ cp -rL examples/website "${ED%/}"/usr/share/doc/${PF}/examples || die
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}