summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-04-26 21:23:04 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-04-26 21:23:04 +0700
commit17620ed01bba76873192e1847764ddde37fb500e (patch)
tree2c68b54e54f716959c25f3a040529bc232df99b9 /app-text
parentwww-client/w3m: fix gettext with eautoreconf (diff)
downloadgentoo-17620ed01bba76873192e1847764ddde37fb500e.tar.gz
gentoo-17620ed01bba76873192e1847764ddde37fb500e.tar.bz2
gentoo-17620ed01bba76873192e1847764ddde37fb500e.zip
app-text/foliate: bump to 2.6.3
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/foliate/Manifest1
-rw-r--r--app-text/foliate/foliate-2.6.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-text/foliate/Manifest b/app-text/foliate/Manifest
index 97f85a834e99..b9a29e2c2129 100644
--- a/app-text/foliate/Manifest
+++ b/app-text/foliate/Manifest
@@ -1,3 +1,4 @@
DIST foliate-2.4.2.tar.gz 4638211 BLAKE2B 4263e047d7251a0f15a2cda2592ba24dbbb9754a37ba6367f0d1e778e3f926cd46777d505e9f92d74bdcd28a722988b60f064f1a841c53a9b2849130941d9481 SHA512 6dda76c9bd3f9f3273bafdd65463adfcab84d9c81ca89c2fd1cda4c5d7618d84610e11c75936c5df2bb118caa3f3e1e77ded506da670263e5af5b0ad92a97a07
DIST foliate-2.5.0.tar.gz 4716094 BLAKE2B c2db3116df1117db06dca93cb3ac47e5f5c627c9e424e5add315f8623b9d71b6cc87112729ce6daa5cdfc81f3b8664555623ba55d6cf674369137ecf0859e321 SHA512 3eb3ecff36a105f6d9ba7e019312bef81e34f62f61310eaf3460c7aea41585fc9b410d08f9e4fd03fe60629b1ebb6f9f6a4c900e898ac712b104c615dc3737c8
DIST foliate-2.6.2.tar.gz 4760966 BLAKE2B 299dd8ab9f489772d18b85749cb312c8ddd4b21855452f87176ddfe068ff9e1e78cb5465fec97dbf70de22e7a773cf0910c11c3be7d0adb19279f4d9813249a1 SHA512 30bff00c34f90bfbd26b9e2b567a7cbcb1243cc5da17ff060762b7f1aafa4159daacee615de7f9bfef7d29d8209c8191094a154564f04321280037d2ec76a63e
+DIST foliate-2.6.3.tar.gz 4822251 BLAKE2B c6cedf4f5ae4e728ab2a7fc35a9fa1e9c69f9d2f8af92060b5363675d5e3fc5cb90698f4b184e792852d66a51e90c361b14d38034149304d10cdacc94100dda7 SHA512 b3dd5bc5a02d3f2210b0c7376426a7ea1668a81fa64fea179da2ab1d852778414cce45171143814d2010d6c03b0287dbbc512884107774ec211e24c6ed8127cb
diff --git a/app-text/foliate/foliate-2.6.3.ebuild b/app-text/foliate/foliate-2.6.3.ebuild
new file mode 100644
index 000000000000..c7f653b4b7a7
--- /dev/null
+++ b/app-text/foliate/foliate-2.6.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PLOCALES="cs de es eu fr id ie it ko nb nl nn pt_BR ru sv tr uk zh_CN zh_TW"
+inherit meson l10n xdg-utils gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+src_prepare() {
+ default
+
+ l10n_find_plocales_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}