summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-06-10 12:21:59 -0700
committerZac Medico <zmedico@gentoo.org>2017-06-10 12:25:33 -0700
commit24598d33ad2f2c5f9c2077ad850fb7516f782bdd (patch)
tree5177fa6b92871001ec3e11dbc1287444b180d9f8 /app-text
parentpackage.use.mask: Mask ICU supprt of Qt:4 on 17.0 profiles (diff)
downloadgentoo-24598d33ad2f2c5f9c2077ad850fb7516f782bdd.tar.gz
gentoo-24598d33ad2f2c5f9c2077ad850fb7516f782bdd.tar.bz2
gentoo-24598d33ad2f2c5f9c2077ad850fb7516f782bdd.zip
app-text/podofo: bug 620934: disable cppunit when possible
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'app-text')
-rw-r--r--app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild b/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild
index 9ac790385034..5c1264949294 100644
--- a/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild
+++ b/app-text/podofo/podofo-0.9.6_pre20170508-r1.ebuild
@@ -38,6 +38,10 @@ src_prepare() {
# equal to ${PV}.
sed -e 's|${PODOFO_VERSION_PATCH}|\0_'${PV##*_}'|' -i CMakeLists.txt || die
+ # bug 620934 - Disable linking with cppunit when possible, since it
+ # triggers errors with some older compilers.
+ use test || sed -e 's:^FIND_PACKAGE(CppUnit):#\0:' -i CMakeLists.txt || die
+
# bug 556962
sed -i -e 's|Decrypt( pEncryptedBuffer, nOutputLen, pDecryptedBuffer, m_lLen );|Decrypt( pEncryptedBuffer, (pdf_long)nOutputLen, pDecryptedBuffer, (pdf_long\&)m_lLen );|' \
test/unit/EncryptTest.cpp || die