summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-23 18:23:19 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-23 18:26:35 +0100
commit27f86cb2820eb8e95b105a3273b24cd4ae7972a4 (patch)
tree7004fd5ead6e5ce1b05d85c07c4124e161ab3711 /app-text
parentsys-libs/argp-standalone: unkeyword 1.4.1 (diff)
downloadgentoo-27f86cb2820eb8e95b105a3273b24cd4ae7972a4.tar.gz
gentoo-27f86cb2820eb8e95b105a3273b24cd4ae7972a4.tar.bz2
gentoo-27f86cb2820eb8e95b105a3273b24cd4ae7972a4.zip
app-text/mathtex: add 1.05
EAPI 5 -> 8, point to CTAN in both HOMEPAGE (the original one is gone) and SRC_URI (instead of the dreaded mirror:gentoo). Fun fact, this version was released in 2014! Gotta love m-n packages. Bug: https://bugs.gentoo.org/826390 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/mathtex/Manifest1
-rw-r--r--app-text/mathtex/mathtex-1.05.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-text/mathtex/Manifest b/app-text/mathtex/Manifest
index b75bc4c44d79..7550548f0e41 100644
--- a/app-text/mathtex/Manifest
+++ b/app-text/mathtex/Manifest
@@ -1 +1,2 @@
DIST mathtex-1.04.zip 148443 BLAKE2B 6632d30536428f6f33fc13a2b5b38651f2ab7a938381166b79c009ab3d95788fc69e8ed824dae64dca00d32bb79ccd00a73b772f9aebc813d54fd6e0f18839f4 SHA512 4b299a6dc503a01d6be3182ad982e38c0b6d926f09a09bd5169f8ad2c947c020ad532b15146379b4bc2158cfceec4cb4a0b7bf902423e0a8ad9b0b0190a99601
+DIST mathtex-1.05.zip 161624 BLAKE2B 9812cfadcc5d47286afb86c6ad38f5bdf932ef39efad2228b04b3b39cbb7543f78be9d82cfa8bbfcc72c9f46fa1931e39aeb71e3abab865dcd60e4e9717e2377 SHA512 f116618de4264efdbccb122b0e9769bbe622f6300266284a96e65f37346c000364063f201b31554bde62a4a4e13c0c8f16d570dca359d3ef27bc0f7622af3715
diff --git a/app-text/mathtex/mathtex-1.05.ebuild b/app-text/mathtex/mathtex-1.05.ebuild
new file mode 100644
index 000000000000..9f8ebe064542
--- /dev/null
+++ b/app-text/mathtex/mathtex-1.05.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lets you easily embed LaTeX math in your own html pages, blogs, wikis, etc"
+HOMEPAGE="https://www.ctan.org/pkg/mathtex"
+SRC_URI="https://mirrors.ctan.org/support/${PN}.zip -> ${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="png"
+
+RDEPEND="app-text/dvipng
+ virtual/latex-base"
+BDEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+
+einfo_run_command() {
+ einfo "${@}"
+ ${@} || die
+}
+
+src_compile() {
+ einfo_run_command $(tc-getCC) \
+ ${CFLAGS} ${LDFLAGS} \
+ -DLATEX=\"/usr/bin/latex\" \
+ -DDVIPNG=\"/usr/bin/dvipng\" \
+ $(use png && echo "-DPNG") \
+ mathtex.c -o mathtex
+}
+
+src_install() {
+ dobin mathtex
+ dodoc README mathtex.html
+}
+
+pkg_postinst() {
+ elog "To use mathtex in your web-pages, just link /usr/bin/mathtex"
+ elog "to your cgi-bin subdirectory!"
+}