summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2016-03-22 16:33:11 +0100
committerChristoph Mende <angelos@gentoo.org>2016-03-22 16:34:45 +0100
commit438475c8954d532b8392245cc630d9f3a76093f2 (patch)
tree0e004baddf6ad3173abb1ab1e49709c08eb9c027 /app-text
parentmedia-sound/mpd: version bump (diff)
downloadgentoo-438475c8954d532b8392245cc630d9f3a76093f2.tar.gz
gentoo-438475c8954d532b8392245cc630d9f3a76093f2.tar.bz2
gentoo-438475c8954d532b8392245cc630d9f3a76093f2.zip
app-text/pastebinit: version bump, shorten description
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pastebinit/Manifest1
-rw-r--r--app-text/pastebinit/pastebinit-1.4.1.ebuild5
-rw-r--r--app-text/pastebinit/pastebinit-1.5.ebuild58
3 files changed, 61 insertions, 3 deletions
diff --git a/app-text/pastebinit/Manifest b/app-text/pastebinit/Manifest
index c00fdc08dea2..0bacd6cdee9d 100644
--- a/app-text/pastebinit/Manifest
+++ b/app-text/pastebinit/Manifest
@@ -1 +1,2 @@
DIST pastebinit-1.4.1.tar.bz2 39202 SHA256 c23720ff19d239f7ae62dd7dc28f453aaea4823af29b1595ba2e58fe232988e6 SHA512 40cfdc22a9d168b239c799ecefca8b9a4f873edeb868803d8de4e57b291f695b9aa3f0b04d87b29ca1777917a53f0c210f20fa8661673630e9a29331e10dc065 WHIRLPOOL 49425b36db3477cd141eee676aa256c8d65567c189dd2cf90bfc53a29824f9611f5d9e54d1d470fdd747bacf141198fe49df7c25c83c96c98da85e3026af3056
+DIST pastebinit-1.5.tar.bz2 42941 SHA256 42e5a84ce7e46825fb3b6478e11893fad357197327257e474bd0d3549f438457 SHA512 cc4b7c46ab7932be3a1064ce7a1d91da3ebf4b132ad44b0090c8d431bfc68e945357344e59ac1239e37b3178de124930c5c8dc552b42f16c39c0452ac9ab8099 WHIRLPOOL 0d20dd1ab5cb10436fc23fae27f090195400cfcfca1b24b860e27f1e5d38d7341c08ae1c8d7cc747e4127e3c8ae634355f796a6308a5a61671210c9581b22481
diff --git a/app-text/pastebinit/pastebinit-1.4.1.ebuild b/app-text/pastebinit/pastebinit-1.4.1.ebuild
index 8abca4fa4293..c7db8674fec6 100644
--- a/app-text/pastebinit/pastebinit-1.4.1.ebuild
+++ b/app-text/pastebinit/pastebinit-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -8,8 +8,7 @@ PYTHON_REQ_USE="xml"
inherit python-single-r1
-DESCRIPTION="A software that lets you send anything you want directly to a
-pastebin from the command line."
+DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
HOMEPAGE="https://launchpad.net/pastebinit"
SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
diff --git a/app-text/pastebinit/pastebinit-1.5.ebuild b/app-text/pastebinit/pastebinit-1.5.ebuild
new file mode 100644
index 000000000000..f2f191d8a9cf
--- /dev/null
+++ b/app-text/pastebinit/pastebinit-1.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="xml"
+
+inherit python-single-r1
+
+DESCRIPTION="A software that lets you send anything you want directly to a pastebin"
+HOMEPAGE="https://launchpad.net/pastebinit"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/configobj[${PYTHON_USEDEP}]
+ crypt? ( app-crypt/gnupg )"
+DEPEND="app-text/docbook-xsl-stylesheets"
+
+src_prepare() {
+ local mo=""
+
+ for lang in ${LINGUAS}; do
+ if [ -f po/${lang}.po ]; then
+ mo="${mo} ${lang}.mo"
+ fi
+ done
+
+ sed -i -e "/^build-mo/s/:.*/:${mo}/" po/Makefile || die
+ sed -i -e "/#!/s/python3/python/" pastebinit || die
+}
+
+src_compile() {
+ emake -C po
+ xsltproc --nonet \
+ "${EROOT}"usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl \
+ pastebinit.xml || die
+}
+
+src_install() {
+ dobin pastebinit utils/pbput
+ python_fix_shebang "${ED}usr/bin/${PN}"
+ dosym pbput /usr/bin/pbget
+ use crypt && dosym pbput /usr/bin/pbputs
+ dodoc README
+ doman pastebinit.1 utils/*.1
+ insinto /usr/share/locale
+ [[ -d po/mo ]] && doins -r po/mo/*
+ insinto /usr/share
+ doins -r pastebin.d
+}