summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2023-10-02 01:17:35 -0400
committerZac Medico <zmedico@gentoo.org>2023-10-17 21:25:57 -0700
commit53fa7ea8170b64b4244dc0af80ccd85bd7248a20 (patch)
tree13beb3d2f2ddb0e52d764388de7671b816554bd5 /app-text
parentapp-text/calibre: 5.44.0-r2 revbump (diff)
downloadgentoo-53fa7ea8170b64b4244dc0af80ccd85bd7248a20.tar.gz
gentoo-53fa7ea8170b64b4244dc0af80ccd85bd7248a20.tar.bz2
gentoo-53fa7ea8170b64b4244dc0af80ccd85bd7248a20.zip
app-text/calibre: add verify-sig support
Historically, calibre has always supported this. Allow checking it. No revbump needed. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/calibre/Manifest1
-rw-r--r--app-text/calibre/calibre-5.44.0-r2.ebuild12
2 files changed, 10 insertions, 3 deletions
diff --git a/app-text/calibre/Manifest b/app-text/calibre/Manifest
index 27588a4b8fc0..15cb62b92968 100644
--- a/app-text/calibre/Manifest
+++ b/app-text/calibre/Manifest
@@ -1,2 +1,3 @@
DIST calibre-5.43.0.tar.xz 38641220 BLAKE2B dddf9e5f7303845f8d86826d38d08dfbf05f144c4fb80d215197f51dc6685f09d848148f00f9795c441f8cd8c541ed9d4988b0a5d2020ce98eb8f8bcd4853dac SHA512 1a5b95c621e47b660841d989445ab56244b9c805aa5d01efc4d95d8c37c5290e93523cedec92a6ca12d16e5f74b63743d6e682bf4084f400d080678ff540a190
DIST calibre-5.44.0.tar.xz 41015696 BLAKE2B c7053e728da20fccfa981ed4f56e24a4d5b382b7687c92ecb039b078fd4828de0529380093e4ab33f77d78aa54a59758c1620cf8f918937a9a64f13decdf77ee SHA512 3d79e76d820cd1a41605dfd4c1d992599a6e4a759e57a8383d42d86982177e4539313f59e647758ab1896ce5874cb2a93c7678bf962e332c44171651aabf0230
+DIST calibre-5.44.0.tar.xz.sig 566 BLAKE2B 413b95855d79bdb5b17ca5d760f834006797b4d3e413604f27d351a3392e16d647e772dc063306bf973e1156c34f68cb38152a66164bca849ebed5484e7f6065 SHA512 59957bf35a73f218241bf76cc86994d5af87cea11d3b0800e83f157bf0b2cfcaf4b6c1314562e74a1141d0c167fdb1619cb9a90e93b67f55dd55ceed77045059
diff --git a/app-text/calibre/calibre-5.44.0-r2.ebuild b/app-text/calibre/calibre-5.44.0-r2.ebuild
index ba8f956e0af1..815415c38fea 100644
--- a/app-text/calibre/calibre-5.44.0-r2.ebuild
+++ b/app-text/calibre/calibre-5.44.0-r2.ebuild
@@ -6,11 +6,15 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
PYTHON_REQ_USE="ipv6(+),sqlite,ssl"
-inherit toolchain-funcs python-single-r1 qmake-utils xdg-utils
+inherit toolchain-funcs python-single-r1 qmake-utils verify-sig xdg-utils
DESCRIPTION="Ebook management application"
HOMEPAGE="https://calibre-ebook.com/"
-SRC_URI="https://download.calibre-ebook.com/${PV}/${P}.tar.xz"
+SRC_URI="
+ https://download.calibre-ebook.com/${PV}/${P}.tar.xz
+ verify-sig? ( https://calibre-ebook.com/signatures/${P}.tar.xz.sig )
+"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/kovidgoyal.gpg"
LICENSE="
GPL-3+
@@ -115,7 +119,9 @@ BDEPEND="$(python_gen_cond_dep '
')
>=virtual/podofo-build-0.9.6_pre20171027
<virtual/podofo-build-0.10
- virtual/pkgconfig"
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-kovidgoyal )
+"
PATCHES=(
# Don't prompt the user for updates - they've installed via