summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-26 21:02:56 +0000
committerSam James <sam@gentoo.org>2020-11-26 21:03:18 +0000
commit54c6d3977e32ae625ad0e15fb0f16bdd0ae53485 (patch)
tree28dbd2ce15a54176c2fce24b6c4f90c4ae6a31cb /app-text
parentnet-analyzer/cloudshark: drop old (diff)
downloadgentoo-54c6d3977e32ae625ad0e15fb0f16bdd0ae53485.tar.gz
gentoo-54c6d3977e32ae625ad0e15fb0f16bdd0ae53485.tar.bz2
gentoo-54c6d3977e32ae625ad0e15fb0f16bdd0ae53485.zip
app-text/u2ps: bump to 1.2
Cloes: https://bugs.gentoo.org/722642 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/u2ps/Manifest1
-rw-r--r--app-text/u2ps/files/u2ps-1.2-respect-ldflags.patch13
-rw-r--r--app-text/u2ps/u2ps-1.2.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/app-text/u2ps/Manifest b/app-text/u2ps/Manifest
index 1e71263526d0..5d645e4c8205 100644
--- a/app-text/u2ps/Manifest
+++ b/app-text/u2ps/Manifest
@@ -1,2 +1,3 @@
DIST u2ps-1.1.tar.gz 110892 BLAKE2B af0dd92d47a8530e8434983132c3bf0f0e6b88ff14cc9d7e73e95c842b4c1dad1b900d91c22a34c8f94373e62382841329e5b2e6b3aa9b51f6e5d6d6d164b596 SHA512 44a470268aafe7b90c17e14a15864924d0ba78b0c8707b9bf076e13b262a9d43d71b6527c5a995f82741e52fe2d07eac6a2626921e7465127a57405d4b5babd3
+DIST u2ps-1.2.tar.gz 110917 BLAKE2B 223aec319d36191032e45a73d9053a970ef76c780c9260e3d6a3799c24f80eb0bddd645de87806570844c3e4e763a2eb1929d44bf122daeaebcefd711d61d35d SHA512 3c5c12b50b6d2d50c67a1051375aeb4cfb32a2c8c898837313ac7ff4a11f30c4625f71f77203f7b1367b1ccdb9143a1106b99deaef8f964af3d08336ce686198
DIST u2ps-full-0.8.4.tar.gz 5496922 BLAKE2B 416a206b768328cf1a268b4706578610e6bed45ee7475d52de515e112e51bbfcc777b2f21603826d52da42b9c6a3bd10dd4e95920e77c14e957ad4a6d0888984 SHA512 31e5c22163a934a3e153ec95e2e5dd94ce79f71a72278a386a6446b1dd053161c896344c51b696c37d838eb3f06fa6fe1db6b5daa55812a06467b2525266363e
diff --git a/app-text/u2ps/files/u2ps-1.2-respect-ldflags.patch b/app-text/u2ps/files/u2ps-1.2-respect-ldflags.patch
new file mode 100644
index 000000000000..a9d4ac5e1ebf
--- /dev/null
+++ b/app-text/u2ps/files/u2ps-1.2-respect-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 8a526f0..88b90b3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -11,7 +11,7 @@ u2ps: u2ps.o u2ps_opts.o u2ps_data.o u2ps_file.o u2ps_page.o u2ps_pswr.o \
+ ttf2pt42: ttf2pt42.o warn.o
+
+ %: %.o
+- $(CC) -o $@ $(filter %.o,$^)
++ $(CC) -o $@ $(filter %.o,$^) ${LDFLAGS}
+
+ .c.o:
+ $(CC) $(CFLAGS) -o $@ -c $<
diff --git a/app-text/u2ps/u2ps-1.2.ebuild b/app-text/u2ps/u2ps-1.2.ebuild
new file mode 100644
index 000000000000..b26e759a2a62
--- /dev/null
+++ b/app-text/u2ps/u2ps-1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="A text to PostScript converter like a2ps, but supports UTF-8"
+HOMEPAGE="https://github.com/arsv/u2ps"
+SRC_URI="https://github.com/arsv/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-text/ghostscript-gpl"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1-nostrip.patch"
+ "${FILESDIR}/${PN}-1.2-respect-ldflags.patch"
+)
+
+src_configure() {
+ # this isnt autoconf, so econf fails...
+ tc-export CC
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ --datadir="${EPREFIX}"/usr/share \
+ --mandir="${EPREFIX}"/usr/share/man \
+ --with-gs="${EPREFIX}"/usr/bin/gs \
+ || die 'configure failed'
+}